Bug 15091 - Batch Checkout Doesn't Tell You it Failed
Summary: Batch Checkout Doesn't Tell You it Failed
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 11759
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 15:28 UTC by Nicole C. Engard
Modified: 2016-06-21 21:40 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
warning? (72.66 KB, image/png)
2015-10-30 15:32 UTC, Nicole C. Engard
Details
Bug 15091: Batch Checkout: Set titles above result tables (1.68 KB, patch)
2015-11-03 19:24 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 15091: Batch Checkout: Tell the user what happens while checking out (3.62 KB, patch)
2015-11-03 20:54 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 15091: Batch Checkout: Tell the user what happens while checking out (3.86 KB, patch)
2015-11-03 21:11 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 15091: Batch Checkout: Set titles above result tables (1.74 KB, patch)
2015-11-03 21:18 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 15091: Batch Checkout: Tell the user what happens while checking out (3.92 KB, patch)
2015-11-03 21:18 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 15091: Do not allow to use batch checkout if checkout is not allowed (1.76 KB, patch)
2015-11-05 10:03 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 15091: Do not allow to use batch checkout if checkout is not allowed (1.78 KB, patch)
2015-11-05 12:10 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 15091: DEBT is IMPOSSIBLE, not NEEDSCONFIRMATION (1.72 KB, patch)
2015-11-05 12:10 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 15091: Do not allow to use batch checkout if checkout is not allowed (1.92 KB, patch)
2015-11-18 14:37 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 15091: DEBT is IMPOSSIBLE, not NEEDSCONFIRMATION (1.85 KB, patch)
2015-11-18 14:38 UTC, Marc Véron
Details | Diff | Splinter Review
[PASSED QA] Bug 15091: Batch Checkout: Set titles above result tables (1.81 KB, patch)
2015-11-19 10:11 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 15091: Do not allow to use batch checkout if checkout is not allowed (1.98 KB, patch)
2015-11-19 10:11 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 15091: DEBT is IMPOSSIBLE, not NEEDSCONFIRMATION (1.92 KB, patch)
2015-11-19 10:11 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2015-10-30 15:28:51 UTC
If you do a batch checkout and the patron is blocked for some reason it shows you a list of the barcodes you scanned, but not warning or confirmation that none of the items were checked out.
Comment 1 Nicole C. Engard 2015-10-30 15:32:24 UTC
Created attachment 44212 [details]
warning?

This image shows that the patron owes money but it doesn't say that it won't be checking out - there are checkboxes next to all of the ones with error.  Then when you confirm it shows you the same titles again but no title on the page to indicate that they did not in fact checkout
Comment 2 Nicole C. Engard 2015-10-30 18:27:19 UTC
Here is a video of what I'm seeing as a big usability issue: http://screencast.com/t/lx6C2zKPxd
Comment 3 Marc Véron 2015-11-03 19:24:46 UTC Comment hidden (obsolete)
Comment 4 Marc Véron 2015-11-03 20:54:58 UTC Comment hidden (obsolete)
Comment 5 Marc Véron 2015-11-03 21:11:44 UTC Comment hidden (obsolete)
Comment 6 Nicole C. Engard 2015-11-03 21:18:44 UTC Comment hidden (obsolete)
Comment 7 Nicole C. Engard 2015-11-03 21:18:48 UTC Comment hidden (obsolete)
Comment 8 Jonathan Druart 2015-11-05 09:48:23 UTC
I don't think the second patch is the right way to fix this problem.
It seems that the complete tool should be blocked if the patron is not able to check out.
I will try to provide a counter patch.
Comment 9 Jonathan Druart 2015-11-05 10:03:13 UTC Comment hidden (obsolete)
Comment 10 Jonathan Druart 2015-11-05 10:04:09 UTC
Marc and Nicole,
Could you please test this patch, I think it's a global fix for this issue.
Comment 11 Marc Véron 2015-11-05 11:09:54 UTC
Jonathan, I tested yout counter patch with following setting:

a) Set loan fee for an item to 5.01
b) Set threshold to 10
c) Do a batch checkout (6 items) for a patron with 0 fines
d) The 'Confirm checkout' dialog shows first item with no Information,
   following intems with information "The patron has a debt of 5.01"
e) Click 'Checkout or renew'
f) Message appears: "Cannot check out! Checkouts are BLOCKED because 
   fine balance is OVER THE LIMIT."
g) Go to Checkout page. 2 of the 6 items are checked out, charges now are on 10.02

This is almost the same confusing situation as described and screencasted by Nicole.

With the patch I proposed and signed-off by Nicole, the user sees what happens.
Comment 12 Jonathan Druart 2015-11-05 12:10:37 UTC Comment hidden (obsolete)
Comment 13 Jonathan Druart 2015-11-05 12:10:45 UTC Comment hidden (obsolete)
Comment 14 Jonathan Druart 2015-11-05 12:11:19 UTC
Could you please try again with the last patches?
Comment 15 Marc Véron 2015-11-05 14:34:06 UTC
Hi Jonathan,

If the patron is over the limit the message appears now as appropriate when going to tab "Batch checkout".

One thing remains: There is no info in the information column about items that
sucsessfully were checked out (like it was in my patch "Batch Checkout: Tell the user what happens while checking out"). The column "Information" now remains empty for sucessfully checked out items.

See discussion with Nicole on IRC around:
http://irc.koha-community.org/koha/2015-11-03#i_1750313
Comment 16 Jonathan Druart 2015-11-05 15:27:04 UTC
(In reply to Marc Véron from comment #15)
> Hi Jonathan,
> 
> If the patron is over the limit the message appears now as appropriate when
> going to tab "Batch checkout".
> 
> One thing remains: There is no info in the information column about items
> that
> sucsessfully were checked out (like it was in my patch "Batch Checkout: Tell
> the user what happens while checking out"). The column "Information" now
> remains empty for sucessfully checked out items.
> 
> See discussion with Nicole on IRC around:
> http://irc.koha-community.org/koha/2015-11-03#i_1750313

That is the expected behavior: if the item has been checked out, nothing in the information column.
But Nicole and you agree that it's better, we could add it.
Comment 17 Nicole Engard (ByWater) 2015-11-12 20:49:24 UTC
I feel there are many improvements we could make here, but as it stands it's usable whereas before it was way too unclear. I'm okay with it going in this way and then us doing some improvements on look and feel and notifications.

Nicole
Comment 18 Marc Véron 2015-11-18 14:37:39 UTC Comment hidden (obsolete)
Comment 19 Marc Véron 2015-11-18 14:38:53 UTC Comment hidden (obsolete)
Comment 20 Marc Véron 2015-11-18 14:43:08 UTC
Set Jonathan as assibnee because he made patches #2 and #3
Comment 21 Katrin Fischer 2015-11-19 10:07:54 UTC
I think there is a room for improvement here - I'd think to be really clear a positive messsage "checked out" and a negative message "not checked out" would really make things easier.
Comment 22 Katrin Fischer 2015-11-19 10:11:26 UTC
I will pass this as a partial improvement - please keep the patches coming (on new bugs of course :)) !
Comment 23 Katrin Fischer 2015-11-19 10:11:51 UTC
Created attachment 44981 [details] [review]
[PASSED QA] Bug 15091: Batch Checkout: Set titles above result tables

This patch is to clarify the results that are displayed while performing
a batch checkout.

It is not the full solution for what is described in the video in
comment #2, but it tells the user what the information in the table
is about.

A second patch is planned to address the case where the issues are confirmed
but not can be fulfilled because the user's fines reach the threshold while
checking out the items.

Signed-off-by: Nicole Engard <nengard@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 24 Katrin Fischer 2015-11-19 10:11:54 UTC
Created attachment 44982 [details] [review]
[PASSED QA] Bug 15091: Do not allow to use batch checkout if checkout is not allowed

If the noissue param is passed to the template, the batch checkout
should not be allowed.

This patch globally fixes the problem raised by bug 15091.
A generic message "cannot check out" is displayed and some more specific
ones could be added later.
For now it only trigger the "fine balance is over the limit" message.

Test plan:
Confirm there is no regression on the original behavior and that the
issue raised on bug 15091 is fixed.

Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 25 Katrin Fischer 2015-11-19 10:11:58 UTC
Created attachment 44983 [details] [review]
[PASSED QA] Bug 15091: DEBT is IMPOSSIBLE, not NEEDSCONFIRMATION

Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 26 Tomás Cohen Arazi 2015-11-19 23:25:30 UTC
Patches pushed to master.

Thanks Marc and Jonathan!