Bug 15118 - Accidental Branch transfer on hold is not handled gracefully.
Summary: Accidental Branch transfer on hold is not handled gracefully.
Status: RESOLVED DUPLICATE of bug 13153
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-03 22:00 UTC by Barton Chittenden
Modified: 2017-02-10 00:49 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Barton Chittenden 2015-11-03 22:00:27 UTC
If an item is accidentally transferred to another branch after it fills a hold, the item will be checked in as 'local use' at the second branch, but will show as being held at the original branch.

To reproduce:

Place a hold for item X at branch ABC
Check item X in at branch ABC, thereby filling the hold.
Check the item in at branch DEF. 


This will produce a message like 

    Hold found: ... 
    Hold for ... 
    Hold at ABC

This will also give the following check in message:

    Check in message
    Not checked out
    Local use recorded

Viewing the item's status will now show that the item's location is DEF, but the item is waiting for pickup at ABC.

The expectation is that a branch transfer should have been created to send the item back to ABC.
Comment 1 Sally 2016-11-11 17:49:24 UTC

*** This bug has been marked as a duplicate of bug 13153 ***