Bug 15137 - List email sent from staff is missing ISBN and author information
Summary: List email sent from staff is missing ISBN and author information
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Lists (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-05 11:22 UTC by Katrin Fischer
Modified: 2017-06-14 22:10 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 15137: Display ISBN and author info when sending list by email (2.21 KB, patch)
2015-11-13 15:21 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 15137: Display ISBN and author info when sending list by email (2.36 KB, patch)
2015-11-14 13:58 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
[PASSED QA] Bug 15137: Display ISBN and author info when sending list by email (2.42 KB, patch)
2015-11-15 23:04 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2015-11-05 11:22:49 UTC
When sending a list email from the staff client, the "Author(s):" information is missing.
Comment 1 Jonathan Druart 2015-11-13 15:21:24 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2015-11-13 15:22:43 UTC
It would be worth having it in 3.22.
Comment 3 Bernardo Gonzalez Kriegel 2015-11-13 19:54:51 UTC
Hi, on current master I get
"Can't call method "get_contents" on an undefined value at $home/kohaclone/virtualshelves/sendshelf.pl line 74"
when sending a list from staff

From opac I can send the list with authors and isbn without patch

This patch is for opac, staff or both?
Comment 4 Jonathan Druart 2015-11-14 11:35:16 UTC
(In reply to Bernardo Gonzalez Kriegel from comment #3)
> Hi, on current master I get
> "Can't call method "get_contents" on an undefined value at
> $home/kohaclone/virtualshelves/sendshelf.pl line 74"
> when sending a list from staff
> 
> From opac I can send the list with authors and isbn without patch
> 
> This patch is for opac, staff or both?

For staff only, it works without this patch at the OPAC.
The error you reported should have been fixed by the patch I have submitted yesterday on bug 14544 comment 242.
Comment 5 Bernardo Gonzalez Kriegel 2015-11-14 13:58:07 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2015-11-15 23:04:23 UTC
Created attachment 44871 [details] [review]
[PASSED QA] Bug 15137: Display ISBN and author info when sending list by email

Disclaimer: this is not caused by bug 14544 :)
And can be backported!

Both isbn and author information are missing when a list is sent by
email.
Emails sent from OPAC and staff should be (almost) the same.

Test plan:
1/ Sent a list by email (Button "Send list")
2/ The email you will receive should contain the isbn and author info

Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com>
On top of last patch of Bug 14544
Works ok, mail with authors and ISBN
No errors

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Tomás Cohen Arazi 2015-11-16 15:56:54 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 8 Frédéric Demians 2015-11-29 20:56:57 UTC
This patch has been pushed to 3.20.x, will be in 3.20.6.
Comment 9 Liz Rea 2016-01-06 21:19:42 UTC
Pushed to 3.18.13, and released.