Bug 15441 - columns_settings.pl: Circulation issues-table - cannot toggle checkin column
Summary: columns_settings.pl: Circulation issues-table - cannot toggle checkin column
Status: RESOLVED DUPLICATE of bug 17346
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: 3.22
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-30 00:01 UTC by Chad Roseburg
Modified: 2019-07-18 15:57 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chad Roseburg 2015-12-30 00:01:27 UTC
Not possible to toggle the checkin column in the issues-table in circulation module. 

A use case scenario describing why a library might want hide this column as described by staff:

"The check-in feature doesn't work for our (mostly) floating collection. The check in option doesn't recognize items that are locally owned and need to route to another branch without a hold on them. This is true for some local history materials, our book club collection, our mail order collection, and our pacific northwest collection. SO: the risk is that our staff are using the batch check in to save themselves time, but then aren't noticing that items need to be transferred and so are shelving items in their locations."

Is it necessary to have this column present? Maybe the enhancement would be to make the checkin feature better at handling these issues rather than allowing it to be hidden.
Comment 1 HB-NEKLS 2016-02-03 03:39:18 UTC
+1 to Chad's suggestion. We have had to hide this column for years with JQuery for the reasons Chad explains. It would be great to hide it through the new columns configuration.
Comment 2 Nick Clemens 2016-03-25 15:00:45 UTC
Just poking around here, making the columns configurable is easily done, but the 'Renew or check in selected items' needs to be altered too if you can hide checkin.  I am wondering if this would be better done as a syspref or as a staff permission?
Comment 3 Christopher Brannon 2017-02-14 19:04:31 UTC
We hide the Check in column with css (display:none) instead of removing the column.  There can be issues with removing a column completely.  This is the simplest method we found.

Anyway, regarding the button, we simply relabel the button with jQuery.  Is it possible to modify the button code to change the label or hide it altogether based on which columns are visible?  So, it would be code right where the button is displayed that would determine what is on the label.

For example, 
* Button normally displays "Renew or check in selected" (The shorter the better)
* Button displays "Renew selected" if the Check in column is hidden
* Button displays "Check in selected" if Renew column is hidden
* Button is hidden if both Renew and Check in columns are hidden (up for discussion if the Renew all button should also be hidden if the renew column is hidden)

I don't think it is wise to have an option for a particular column in a separate preference.  It makes sense to have it all together like this.  Keeps it simple.
Comment 4 Jonathan Druart 2017-04-03 14:06:47 UTC

*** This bug has been marked as a duplicate of bug 17346 ***