Bug 15493 - Export records using a CSV profile does not work
Summary: Export records using a CSV profile does not work
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 14722
Blocks: 15498
  Show dependency treegraph
 
Reported: 2016-01-06 16:18 UTC by Jonathan Druart
Modified: 2019-06-27 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15493: Use the correct CSV profile when exporting records from the export tool (1.55 KB, patch)
2016-01-06 16:22 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 15493: Use the correct CSV profile when exporting records from the export tool (1.64 KB, patch)
2016-01-06 21:33 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
[PASSED QA] Bug 15493: Use the correct CSV profile when exporting records from the export tool (1.70 KB, patch)
2016-01-06 22:24 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-01-06 16:18:57 UTC
The CSV profile used is not the one the user has chosen, but the one defined in the pref ExportWithCsvProfile
Comment 1 Jonathan Druart 2016-01-06 16:22:41 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2016-01-06 16:22:58 UTC
Affect 3.22
Comment 3 Héctor Eduardo Castro Avalos 2016-01-06 21:33:12 UTC Comment hidden (obsolete)
Comment 4 Katrin Fischer 2016-01-06 22:24:24 UTC
Created attachment 46372 [details] [review]
[PASSED QA] Bug 15493: Use the correct CSV profile when exporting records from the export tool

The CSV profile used is not the one the user has chosen, but the one
defined in the pref ExportWithCsvProfile.

It's caused by a wrong variable name csv_profile vs csv_profile_id

Test plan:
Define 1+ csv profiles
Set ExportWithCsvProfile with 1 of these profile
Use the export tool to export some records using a csv profile.
Without this patch, the csv profile used, will always be the one defined
in ExportWithCsvProfile.

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Works as descrived

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Brendan Gallagher 2016-01-07 18:47:32 UTC
Pushed to Master - Thanks.
Comment 6 Julian Maurice 2016-01-12 13:47:01 UTC
Patch pushed to 3.22.x, will be in 3.22.2