Bug 15517 - Tables borrowers and deletedborrowers differ again
Summary: Tables borrowers and deletedborrowers differ again
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
: 14067 (view as bug list)
Depends on: 15478
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 15:22 UTC by Jonathan Druart
Modified: 2017-06-14 22:08 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15517: Resync borrowers and deletedborrowers tables (2.30 KB, patch)
2016-01-07 15:28 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 15517: deleted* tables won't never differ anymore! (2.63 KB, patch)
2016-01-07 15:28 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 15517: Resync borrowers and deletedborrowers tables (2.37 KB, patch)
2016-01-09 03:40 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 15517: deleted* tables won't never differ anymore! (2.74 KB, patch)
2016-01-09 03:41 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
[PASSED QA] Bug 15517: Resync borrowers and deletedborrowers tables (2.43 KB, patch)
2016-01-10 23:25 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 15517: deleted* tables won't never differ anymore! (2.79 KB, patch)
2016-01-10 23:25 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 15517: Change wording for tests (1.27 KB, patch)
2016-01-11 08:36 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-01-07 15:22:33 UTC
The structure of borrowers and deletedborrowers differs again.
Comment 1 Jonathan Druart 2016-01-07 15:28:42 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2016-01-07 15:28:46 UTC Comment hidden (obsolete)
Comment 3 Héctor Eduardo Castro Avalos 2016-01-09 03:40:47 UTC Comment hidden (obsolete)
Comment 4 Héctor Eduardo Castro Avalos 2016-01-09 03:41:13 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2016-01-10 23:10:16 UTC
Hi Jonathan,

thx for catching this!

Something weird: After applying the patch and running the database update (I verified in MySQL Workbench that both tables match now) I still have the 2 tests failing for password and userid. It seems like it's not looking at the right db or has outdated information.

Do you have an idea why this could happen?

The other thing - shouldn't the test message not be:

ok - ... don't differ ...?
Comment 6 Katrin Fischer 2016-01-10 23:17:30 UTC
... should read better...
misc/devel/update_dbix_class_files.pl
Comment 7 Katrin Fischer 2016-01-10 23:25:25 UTC
Created attachment 46466 [details] [review]
[PASSED QA] Bug 15517: Resync borrowers and deletedborrowers tables

The 2 columns password and userid are not sync and could cause errors
when deleting patrons.

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Katrin Fischer 2016-01-10 23:25:59 UTC
Created attachment 46467 [details] [review]
[PASSED QA] Bug 15517: deleted* tables won't never differ anymore!

These tests will ensure that the 4 deleted* tables won't never differ
anymore.

Test plan:
0/ Do not execute the update DB entry
1/ prove t/db_dependent/db_structure.t
should fail
2/ Execute the update DB entry and update the schema with
misc/devel/update_dbix_class_files.pl
3/ prove t/db_dependent/db_structure.t
should now be happy

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Test pass successfuly. Works as advertised

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 9 Jonathan Druart 2016-01-11 08:36:07 UTC
Created attachment 46472 [details] [review]
Bug 15517: Change wording for tests
Comment 10 Jonathan Druart 2016-01-11 08:36:32 UTC
(In reply to Katrin Fischer from comment #5)
> The other thing - shouldn't the test message not be:
> 
> ok - ... don't differ ...?

Yep! Fixed.
Comment 11 Brendan Gallagher 2016-02-23 23:14:26 UTC
Pushed to Master - Should be in the May 2016 Release.  Thanks!
Comment 12 Julian Maurice 2016-02-26 14:20:43 UTC
Patches pushed to 3.22.x, will be in 3.22.4
Comment 13 Frédéric Demians 2016-03-01 16:53:23 UTC
This patch has been pushed to 3.20.x, will be in 3.20.9.
Comment 14 Barton Chittenden 2016-06-29 12:51:27 UTC
*** Bug 14067 has been marked as a duplicate of this bug. ***