Bug 15674 - 'Show/hide columns' is not translatable
Summary: 'Show/hide columns' is not translatable
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-26 16:17 UTC by Katrin Fischer
Modified: 2017-06-14 22:05 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15674: Make "Column visibility" translatable (1.18 KB, patch)
2016-02-29 07:35 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 15674: Make "Column visibility" translatable (1.25 KB, patch)
2016-03-01 01:08 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 15674: Use double-quote instead of simple-quote (1.01 KB, patch)
2016-03-01 08:36 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 15674: Make "Column visibility" translatable (1.30 KB, patch)
2016-03-01 22:56 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 15674: Use double-quote instead of simple-quote (1.08 KB, patch)
2016-03-01 22:58 UTC, Katrin Fischer
Details | Diff | Splinter Review
[3.22] Bug 15674: Make "Column visibility" translatable (1.40 KB, patch)
2016-03-07 09:14 UTC, Julian Maurice
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2016-01-26 16:17:04 UTC
The 'Show/hide columns' button for changing the columns on a table configured under administration > columns configuration is not translatable.
Comment 1 Aleisha Amohia 2016-02-10 01:19:10 UTC
Would it be better to say something like 'Toggle columns'? What kind of change do you think is best?
Comment 2 Katrin Fischer 2016-02-10 01:20:44 UTC
Hi Aleisha, the problem is not the wording - the strings don't seem to show up in the po files so they can't be translated and remain in English. Actually finding a not too long translation in German will be the next problem then :)
Comment 3 Aleisha Amohia 2016-02-10 01:25:43 UTC
Oh I see :-) Will leave for someone with a bit more knowledge of the po files etc to work on
Comment 4 Katrin Fischer 2016-02-22 22:15:04 UTC
Would be nice to see this fixed.
Comment 5 Owen Leonard 2016-02-23 13:40:09 UTC
Based on the documentation this should be a simple fix:

http://datatables.net/extensions/colvis/options

"buttonText: 'Select columns'"

However I'm unfamiliar with the colVis configuration system so it's not obvious to me where that setting should go.
Comment 6 Jonathan Druart 2016-02-29 07:35:58 UTC Comment hidden (obsolete)
Comment 7 Aleisha Amohia 2016-03-01 01:08:28 UTC Comment hidden (obsolete)
Comment 8 Katrin Fischer 2016-03-01 06:45:09 UTC
The QA tool is complaining :(

 FAIL	koha-tmpl/intranet-tmpl/prog/en/includes/columns_settings.inc
   FAIL	  forbidden patterns
		forbidden pattern: simple-quote string (line 29)
Comment 9 Jonathan Druart 2016-03-01 08:36:57 UTC Comment hidden (obsolete)
Comment 10 Katrin Fischer 2016-03-01 22:56:26 UTC
Created attachment 48525 [details] [review]
[PASSED QA] Bug 15674: Make "Column visibility" translatable

The "Column visibility" text button was not translatable, now it is.

Test plan:
1/ Update the template for a given language and translate the "Column
visibility" string
2/ Go on admin/currency.pl
=> The string should be translated.

Signed-off-by: Aleisha <aleishaamohia@hotmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 11 Katrin Fischer 2016-03-01 22:58:39 UTC
Created attachment 48526 [details] [review]
[PASSED QA] Bug 15674: Use double-quote instead of simple-quote

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 12 Brendan Gallagher 2016-03-02 01:02:34 UTC
Pushed to Master - Should be in the May 2016 Release.  Thanks!
Comment 13 Julian Maurice 2016-03-07 09:14:10 UTC
Created attachment 48726 [details] [review]
[3.22] Bug 15674: Make "Column visibility" translatable

Patch for 3.22.x
Comment 14 Julian Maurice 2016-03-07 09:15:03 UTC
Patch pushed to 3.22.x, will be in 3.22.5
Comment 15 Frédéric Demians 2016-03-15 08:58:05 UTC
This patch has been pushed to 3.20.x, will be in 3.20.10.