Bug 15697 - Unnecessary comma between title and subtitle on opac-detail.pl
Summary: Unnecessary comma between title and subtitle on opac-detail.pl
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-28 20:33 UTC by Nick Clemens
Modified: 2017-06-14 22:05 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15697 - Unnecessary comma between title and subtitle on opac-detail.pl (2.49 KB, patch)
2016-01-28 20:50 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 15697 - Unnecessary comma between title and subtitle on opac-detail.pl (2.44 KB, patch)
2016-02-01 16:32 UTC, Nick Clemens
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 15697: Unnecessary comma between title and subtitle on opac-detail.pl (2.60 KB, patch)
2016-02-01 17:13 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 15697 - [QA Followup] Apply change to NORMARC (2.12 KB, patch)
2016-02-02 14:33 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 15697: Unnecessary comma between title and subtitle on opac-detail.pl (2.65 KB, patch)
2016-02-03 12:24 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 15697 - [QA Followup] Apply change to NORMARC (2.19 KB, patch)
2016-02-03 12:24 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 15697: Unnecessary comma between title and subtitle on opac-detail.pl (2.69 KB, patch)
2016-02-24 15:39 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 15697 - [QA Followup] Apply change to NORMARC (2.24 KB, patch)
2016-02-24 15:39 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2016-01-28 20:33:45 UTC
To reproduce:
1 - Go to Administration->Keyword to MARC mapping
2 - Add a mapping
    Field name: subtitle
    MARC field: 245 
    MARC subfield: b
(or 200$e I think for UNIMARC)
3 - View a record with a subtitle in the opac
4 - Note in MARC 21 you have "Title of record:, subtitle of record"
Comment 1 Nick Clemens 2016-01-28 20:50:59 UTC Comment hidden (obsolete)
Comment 2 Nick Clemens 2016-02-01 16:32:39 UTC Comment hidden (obsolete)
Comment 3 Héctor Eduardo Castro Avalos 2016-02-01 17:13:47 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2016-02-02 11:12:21 UTC
What about NORMARC? I guess it micmics MARC21.
Comment 5 Nick Clemens 2016-02-02 14:33:10 UTC Comment hidden (obsolete)
Comment 6 Nick Clemens 2016-02-02 14:34:10 UTC
(In reply to Jonathan Druart from comment #4)
> What about NORMARC? I guess it micmics MARC21.

I wasn't certain so erred on leaving as is.  Updated patch to use IF UNIMARC instead of UNLESS MARC21
Comment 7 Jonathan Druart 2016-02-03 12:24:18 UTC Comment hidden (obsolete)
Comment 8 Jonathan Druart 2016-02-03 12:24:23 UTC Comment hidden (obsolete)
Comment 9 Jonathan Druart 2016-02-03 12:25:48 UTC
Joubu: magnuse: could you confirm my comment on bug 15697 comment 4 about NORMARC please?
magnuse: Joubu: the qa followup looks good. and yes, marc21 and normarc are very similar in most regards
Comment 10 Nick Clemens 2016-02-24 15:39:47 UTC
Created attachment 48341 [details] [review]
Bug 15697: Unnecessary comma between title and subtitle on opac-detail.pl

To test:
1 - Go to Administration->Keyword to MARC mapping
2 - Add a mapping (or ensure it exists)
    Field name: subtitle
    MARC field: 245
    MARC subfield: b
3 - View a record with a subtitle in the opac
4 - Note in MARC 21 you have "Title of record:, subtitle of record"
5 - Apply patch
6 - View the record again and note the comma is no longer present.

Note: this patch removes the comma only for MARC21 where subtitle is not
repeatable. UNIMARC seems to be repeatable and does not include
punctuation so I believe this may be needed there.

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Works as described. Comma removed from title of the window and breadcrumb
section

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 11 Nick Clemens 2016-02-24 15:39:52 UTC
Created attachment 48342 [details] [review]
Bug 15697 - [QA Followup] Apply change to NORMARC

This patch switches from UNLESS MARC21 to IF UNIMARC - this way changes
apply to MARC21 and NORMARC and UNIMARC remains unaffected

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 12 Kyle M Hall 2016-02-26 14:11:41 UTC
Pushed to master! Should be in Koha 3.24, thanks Nick!
Comment 13 Julian Maurice 2016-03-07 13:26:27 UTC
Patches pushed to 3.22.x, will be in 3.22.5
Comment 14 Frédéric Demians 2016-03-15 09:03:55 UTC
This patch has been pushed to 3.20.x, will be in 3.20.10.