Bug 15733 - Audio Alerts issues in master
Summary: Audio Alerts issues in master
Status: RESOLVED DUPLICATE of bug 15734
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P3 normal (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
Depends on: 11431 13618 15734
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 19:01 UTC by Nick Clemens
Modified: 2016-03-07 19:46 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15733: Fix audio alerts (1.21 KB, patch)
2016-02-04 08:26 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2016-02-03 19:01:09 UTC
In master there is a JSON error thrown when AudioAlerts are enabled.  When checking in I get:
SyntaxError: JSON.parse: expected property name or '}' at line 1 column 3 of the JSON data

This does not happen in 3.22


Also (in master and 3.22) single quotes audio selector break ability to edit an alert
Comment 1 Jonathan Druart 2016-02-04 08:26:25 UTC
Created attachment 47636 [details] [review]
Bug 15733: Fix audio alerts

Bug 13618 has broken the audio alerts.

Test plan:
Enable the AudioAlerts pref
Check an item in
Without this patch, there is a js error
With this patch applied, the error is gone
Comment 2 Jonathan Druart 2016-02-04 10:21:07 UTC

*** This bug has been marked as a duplicate of bug 15734 ***