Bug 15932 - Moving Authorities actions into a drop-down menu
Summary: Moving Authorities actions into a drop-down menu
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Authority data support (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Aleisha Amohia
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-29 00:52 UTC by Aleisha Amohia
Modified: 2016-12-05 21:27 UTC (History)
4 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
auth search results (24.98 KB, image/png)
2016-02-29 00:52 UTC, Aleisha Amohia
Details
Bug 15932: Moving Authorities actions into a drop-down menu (4.99 KB, patch)
2016-03-01 22:12 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 15932: Moving Authorities actions into a drop-down menu (5.13 KB, patch)
2016-03-02 06:31 UTC, Frédéric Demians
Details | Diff | Splinter Review
Bug 15932: Moving Authorities actions into a drop-down menu (4.56 KB, patch)
2016-03-03 01:46 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 15932: Moving Authorities actions into a drop-down menu (4.55 KB, patch)
2016-03-06 22:20 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 15932: Moving Authorities actions into a drop-down menu (4.61 KB, patch)
2016-03-08 20:47 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 15932: Moving Authorities actions into a drop-down menu (4.68 KB, patch)
2016-03-10 02:18 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 15932: Moving Authorities actions into a drop-down menu (4.56 KB, patch)
2016-03-13 21:07 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 15932: Moving Authorities actions into a drop-down menu (4.64 KB, patch)
2016-03-22 01:20 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Drop down very wide (33.86 KB, image/png)
2016-03-23 09:23 UTC, Marc Véron
Details
Bug 15932: Moving Authorities actions into a drop-down menu (4.59 KB, patch)
2016-03-23 11:30 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 15932: Moving Authorities actions into a drop-down menu (4.66 KB, patch)
2016-03-23 21:25 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Aleisha Amohia 2016-02-29 00:52:26 UTC
Created attachment 48420 [details]
auth search results

To reproduce:

Do an authority search on authorities-home.pl
Notice actions (Edit, Merge, Delete) can be styled as a drop down menu (see Bug 15830, Bug 13778), see attachment
Comment 1 Aleisha Amohia 2016-03-01 22:12:10 UTC Comment hidden (obsolete)
Comment 2 Frédéric Demians 2016-03-02 06:31:47 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2016-03-02 07:15:09 UTC
Hi, I think the menu is a good idea, but the datatable doesn't work here. If you have more than 20 results, the authority search has its own paging - you won't be able to use the paging from the datatables for your results. 

Also - this change is not part of the bug description!
Comment 4 Aleisha Amohia 2016-03-03 01:46:48 UTC Comment hidden (obsolete)
Comment 5 Aleisha Amohia 2016-03-06 22:20:35 UTC Comment hidden (obsolete)
Comment 6 Nicole C. Engard 2016-03-08 20:47:56 UTC Comment hidden (obsolete)
Comment 7 Jonathan Druart 2016-03-09 11:50:05 UTC
QA comment:
There is a wrong behavior: Click on Actions > Delete > Cancel
=> The scrollbar goes to the top
Comment 8 Aleisha Amohia 2016-03-10 02:18:05 UTC Comment hidden (obsolete)
Comment 9 Owen Leonard 2016-03-11 19:11:27 UTC
Was this change intentional? It's a regression from Bug 15927.

+      [% UNLESS ( loop.odd ) %]
+        <tr data-authid="[% resul.authid %]" class="highlight">
+      [% ELSE %]
+        <tr data-authid="[% resul.authid %]">
+      [% END %]
Comment 10 Aleisha Amohia 2016-03-13 21:07:27 UTC Comment hidden (obsolete)
Comment 11 M. Tompsett 2016-03-21 01:52:01 UTC
Comment on attachment 49062 [details] [review]
Bug 15932: Moving Authorities actions into a drop-down menu

Review of attachment 49062 [details] [review]:
-----------------------------------------------------------------

I don't think comment #9 was dealt with.

::: koha-tmpl/intranet-tmpl/prog/en/modules/authorities/searchresultlist.tt
@@ -73,5 @@
> -      <th>&nbsp;</th>
> -    [% END %]
> -    </tr>
> -[% FOREACH resul IN result %]
> -    <tr data-authid="[% resul.authid %]">

I think you should have kept this <tr> line.
Comment 12 Aleisha Amohia 2016-03-22 01:20:01 UTC Comment hidden (obsolete)
Comment 13 Marc Véron 2016-03-23 09:23:20 UTC
Created attachment 49432 [details]
Drop down very wide

The drop down list is very wide, is that intended?
Comment 14 Aleisha Amohia 2016-03-23 09:55:14 UTC
(In reply to Marc Véron from comment #13)
> Created attachment 49432 [details]
> Drop down very wide
> 
> The drop down list is very wide, is that intended?

Not intended, and not really sure why it's happening.
Comment 15 Marc Véron 2016-03-23 11:29:07 UTC
It has the same with as on /cgi-bin/koha/acqui/invoices.pl

Seems to be related to the class dropdown-menu ( min-width: 160px; )

Signing off.
Comment 16 Marc Véron 2016-03-23 11:30:21 UTC Comment hidden (obsolete)
Comment 17 Jonathan Druart 2016-03-23 21:25:17 UTC
Created attachment 49464 [details] [review]
Bug 15932: Moving Authorities actions into a drop-down menu

Edit: Removed datatables stuff and fixed merge conflict
Edit: Removed code from Comment 9 (no it wasn't intentional)
Edit: Putting <tr> line back

To test:
1) Go to Authorities and do an authority search (authorities-home.pl)
2) Confirm that the options (Edit, Merge, Delete) are there and behave
   as expected.
EDIT: 3) Click Delete then Cancel, confirm page does not scroll to the top

Sponsored-by: Catalyst IT
Signed-off-by: Frédéric Demians <f.demians@tamil.fr>

Signed-off-by: Nicole C Engard <nengard@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 18 Brendan Gallagher 2016-03-24 17:27:26 UTC
Pushed to Master - Should be in the May 2016 release.  Thanks!