Bug 15973 - Do not disable syspref cache for Plack
Summary: Do not disable syspref cache for Plack
Status: RESOLVED DUPLICATE of bug 11998
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 13805
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 16:44 UTC by Jonathan Druart
Modified: 2016-03-10 10:15 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 15973: Revert "Bug 13805: (Plack) Disable syspref cache" (1.17 KB, patch)
2016-03-03 16:46 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 15973: follow-up for the debian package psgi file (725 bytes, patch)
2016-03-03 16:53 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-03-03 16:44:42 UTC
Bug 13805 fixes an installer bug by disabling the syspref cache.
It was not a good idea, it introduced performance issues (see bug 13805 comment 14).
Comment 1 Jonathan Druart 2016-03-03 16:46:41 UTC
Created attachment 48636 [details] [review]
Bug 15973: Revert "Bug 13805: (Plack) Disable syspref cache"

This reverts commit ca00f0ddaeb76106b4aa274fd1848844ae042f58.

Bug 13805 fixes an installer bug by disabling the syspref cache.
It was not a good idea, it introduced performance issues (see bug 13805
comment 14).

Test plan:
Test plan:
0/ Create a new database and fill the database entry in the koha conf
with its name
1/ Go on the mainpage, you should be redirected to the installer
2/ Try to log in
You should not get the login form again.
Comment 2 Jonathan Druart 2016-03-03 16:53:25 UTC
Created attachment 48638 [details] [review]
Bug 15973: follow-up for the debian package psgi file
Comment 3 Jonathan Druart 2016-03-10 10:15:11 UTC
Moved to bug 11998.

*** This bug has been marked as a duplicate of bug 11998 ***