Bug 16136 - Koha::Patron contains 'return undef' and fails critic tests
Summary: Koha::Patron contains 'return undef' and fails critic tests
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Tomás Cohen Arazi
QA Contact: Testopia
URL:
Keywords:
Depends on: 15656
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-23 17:57 UTC by Tomás Cohen Arazi
Modified: 2016-12-05 21:23 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16136: Koha::Patron contains 'return undef' and fails critic tests (1.12 KB, patch)
2016-03-23 18:03 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 16136: Koha::Patron contains 'return undef' and fails critic tests (1.19 KB, patch)
2016-03-23 19:45 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2016-03-23 17:57:02 UTC
To reproduce:

- Run
  $ TEST_QA=1 prove t/00-testcritic.t
=> FAIL: Koha::Patron makes the tests fail.

While a minor issue, this is really important because the packages build procedure runs the db-independent tests and they need to pass!
Comment 1 Tomás Cohen Arazi 2016-03-23 18:03:14 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2016-03-23 19:45:47 UTC
Created attachment 49458 [details] [review]
Bug 16136: Koha::Patron contains 'return undef' and fails critic tests

This patch fixes this issue.

To test:
- Run
  $ TEST_QA=1 prove t/00-testcritic.t
=> FAIL: Koha::Patron makes the tests fail.
- Apply the patch
- Run
  $ TEST_QA=1 prove t/00-testcritic.t
=> SUCCESS: tests PASS
- Sign off

Regards

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 3 Jonathan Druart 2016-03-23 19:46:07 UTC
Skipping QA.
Comment 4 Brendan Gallagher 2016-03-24 15:36:08 UTC
Pushed to Master - Should be in the May 2016 release.  Thanks!
Comment 5 Julian Maurice 2016-04-07 07:51:12 UTC
Not needed in stable versions, status changed to RESOLVED