Bug 16328 - datatables on opac-suggestions.pl broken by js error
Summary: datatables on opac-suggestions.pl broken by js error
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 15044
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-22 23:44 UTC by Nick Clemens
Modified: 2016-12-05 21:23 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16328: follow-up for bug 15044 - Fix datatable error (1.19 KB, patch)
2016-04-23 06:23 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 16328: follow-up for bug 15044 - Fix datatable error (1.38 KB, patch)
2016-04-24 00:51 UTC, M. Tompsett
Details | Diff | Splinter Review
[PASSED QA] Bug 16328: follow-up for bug 15044 - Fix datatable error (1.45 KB, patch)
2016-04-24 21:12 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2016-04-22 23:44:00 UTC
When attempting to view a users purchase suggestions I get an error:

TypeError: c is undefined

And table sorting/functions are broken


To reproduce:
Sign in to opac
Enter some purchase suggestions
See table is broken
Comment 1 Owen Leonard 2016-04-23 01:14:25 UTC
Bug 15883 shouldn't be related to this but g because it didn't touch the OPAC.
Comment 2 Jonathan Druart 2016-04-23 06:23:47 UTC Comment hidden (obsolete)
Comment 3 M. Tompsett 2016-04-24 00:51:37 UTC Comment hidden (obsolete)
Comment 4 Katrin Fischer 2016-04-24 21:12:45 UTC
Created attachment 50600 [details] [review]
[PASSED QA] Bug 16328: follow-up for bug 15044 - Fix datatable error

Bug 15044 added a new column to the suggestion table at the OPAC but
forgot to modify the DT params.

Test plan:
The suggestion table at the OPAC should not be broken with this patch.

NOTE: Sorting was broken prior to patch.
      Sorting was fixed after patch.
      The added null causes the field count to match up properly.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Brendan Gallagher 2016-04-26 16:47:15 UTC
Pushed to Master - Should be in the May 2016 Release.  Thanks
Comment 6 Julian Maurice 2016-05-16 08:21:21 UTC
Not needed in stable versions, status changed to RESOLVED