Bug 16449 - unimarc_field_4XX raises a warning
Summary: unimarc_field_4XX raises a warning
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Marcel de Rooy
URL:
Keywords:
: 16856 (view as bug list)
Depends on: 14828
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-05 14:25 UTC by Jonathan Druart
Modified: 2017-12-07 22:16 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16449: Remove "no method selected" warning from unimarc_field_4XX (1.63 KB, patch)
2016-05-05 14:28 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 16449: Remove "no method selected" warning from unimarc_field_4XX (1.79 KB, patch)
2016-07-19 14:59 UTC, Mark Tompsett
Details | Diff | Splinter Review
Bug 16449: Remove "no method selected" warning from unimarc_field_4XX (1.89 KB, patch)
2016-09-02 09:41 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-05-05 14:25:44 UTC
Because of bug 14828, the unimarc_field_4XX now raises a warning:
"No method selected!"

There are no need to select an item type on this page, the default (all) is always selected.
Comment 1 Jonathan Druart 2016-05-05 14:28:57 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2016-07-15 14:12:51 UTC
*** Bug 16856 has been marked as a duplicate of this bug. ***
Comment 3 Mark Tompsett 2016-07-19 14:59:04 UTC Comment hidden (obsolete)
Comment 4 Marcel de Rooy 2016-09-02 09:41:22 UTC
Created attachment 55109 [details] [review]
Bug 16449: Remove "no method selected" warning from unimarc_field_4XX

Because of bug 14828, the unimarc_field_4XX now raises a warning:
"No method selected!"

There are no need to select an item type on this page, the default (all)
is always selected.

Test plan:
Link the unimarc_field_4XX value builder with on of the subfield
Edit a record, click on the value builder icon
Note the warning without the patch and that it's gone with the patch
applied

NOTE: Code fix that I derived was identical. Ran
 prove t/db_dependent/FrameworkPlugin.t
to confirm it works.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>
Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 5 Kyle M Hall 2016-09-02 14:56:31 UTC
Pushed to master for 16.11, thanks Jonathan!
Comment 6 Frédéric Demians 2016-09-08 19:29:11 UTC
Pushed in 16.05. Will be in 16.05.04.