Bug 16584 - All SQL queries should be compatible to 'ONLY_FULL_GROUP_BY'.
Summary: All SQL queries should be compatible to 'ONLY_FULL_GROUP_BY'.
Status: RESOLVED DUPLICATE of bug 17258
Alias: None
Product: Koha
Classification: Unclassified
Component: Database (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
: 16564 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-25 03:59 UTC by Son Nguyen
Modified: 2017-01-07 23:52 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Son Nguyen 2016-05-25 03:59:06 UTC
As the mode 'ONLY_FULL_GROUP_BY' is ON by default on MySQL 5.7, non ONLY_FULL_GROUP_BY queries in Koha will be rejected.

This caused several issue including the error when adding a new patron even the patron categories exist.
Comment 1 Katrin Fischer 2016-06-09 05:41:46 UTC
*** Bug 16564 has been marked as a duplicate of this bug. ***
Comment 2 Katrin Fischer 2017-01-07 23:52:13 UTC
Marking this duplicate to the omnibus bug for supporting newer MySQL versions.

*** This bug has been marked as a duplicate of bug 17258 ***