Bug 16618 - 00-load.t prematurely stops all testing
Summary: 00-load.t prematurely stops all testing
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Test Suite (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Mark Tompsett
QA Contact: Galen Charlton
URL:
Keywords:
: 16657 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-30 15:46 UTC by Mark Tompsett
Modified: 2017-12-07 22:17 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16618: 00-load.t prematurely stops all testing (4.23 KB, patch)
2016-05-30 16:33 UTC, Mark Tompsett
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 16618: 00-load.t prematurely stops all testing (4.27 KB, patch)
2016-06-06 05:10 UTC, Srdjan Jankovic
Details | Diff | Splinter Review
Bug 16618: 00-load.t prematurely stops all testing (4.35 KB, patch)
2016-06-06 20:13 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 16618: 00-load.t prematurely stops all testing (4.40 KB, patch)
2016-06-07 01:13 UTC, Galen Charlton
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Tompsett 2016-05-30 15:46:06 UTC
Rather than add/remove regular expressions to skip modules (like bug 9054), encapsulate the decision logic into a separate function.

Currently there are three libraries which trigger halts:
Koha::NorwegianDB (which was already there)
Koha::ElasticSearch::Indexer
Koha::SearchEngine::Elasticsearch::Search

This number should always be relatively small, if not 0.
Comment 1 Mark Tompsett 2016-05-30 16:33:08 UTC Comment hidden (obsolete)
Comment 2 Srdjan Jankovic 2016-06-06 05:10:03 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2016-06-06 20:04:26 UTC
*** Bug 16657 has been marked as a duplicate of this bug. ***
Comment 4 Jonathan Druart 2016-06-06 20:13:38 UTC Comment hidden (obsolete)
Comment 5 Galen Charlton 2016-06-07 01:13:13 UTC
Created attachment 52106 [details] [review]
Bug 16618: 00-load.t prematurely stops all testing

Rather than add/remove regular expressions to skip modules (like bug 9054), encapsulate the decision logic into a separate function.

Currently there are three libraries which trigger halts:
Koha::NorwegianDB (which was already there)
Koha::ElasticSearch::Indexer
Koha::SearchEngine::Elasticsearch::Search

TEST PLAN
---------
1) prove t/00-load.t
   -- should barf horribly on Catmandu stuff
      if not: sudo apt-get remove libcatmandu-marc-perl
      then repeat step.
2) apply patch
3) prove t/00-load.t
   -- should not barf horribly
4) run koha qa test tools

NOTE: The four optional modules for Koha::NorwegianDB are
      listed in the PerlDependencies.pm, while there is
      no mention of Catmandu libraries at all there.
      This may be another bug which needs fixing.

TECH NOTES (for ideas of how to tinker around):
These three things should trigger the three module cases:
sudo apt-get remove libcatmandu-marc-perl
sudo apt-get remove libcatmandu-store-elasticsearch-perl
sudo apt-get remove libconvert-basen-perl

You probably had koha-perldeps installed before, so the following wil mostly fix:
sudo apt-get install koha-perldeps libcatmandu-marc-perl

And in case you didn't have elastic search stuff installed:
echo deb http://packages.elastic.co/elasticsearch/1.7/debian stable main | sudo tee /etc/apt/sources.list.d/elasticsearch.list
wget -O- https://packages.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add -
sudo apt-get update

cd ~
wget http://debian.koha-community.org/koha/otherthings/elasticsearch_deps.tar.gz
tar xvf elasticsearch_deps.tar.gz
cd es_deps
sudo dpkg i lib*
sudo apt-get install -f

Signed-off-by: Srdjan <srdjan@catalyst.net.nz>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Signed-off-by: Galen Charlton <gmcharlt@gmail.com>
Comment 6 Kyle M Hall 2016-06-10 16:57:47 UTC
Pushed to master for 16.11, thanks Mark!
Comment 7 Frédéric Demians 2016-06-15 07:43:19 UTC
Pushed in 16.05. Will be in 16.05.01.