Bug 16645 - Plack: Add the multi_param fix from Context in koha.psgi
Summary: Plack: Add the multi_param fix from Context in koha.psgi
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Marcel de Rooy
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 15809
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-03 10:38 UTC by Marcel de Rooy
Modified: 2017-06-14 22:10 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 16645: Plack: Add the multi_param fix from Context in koha.psgi (1.11 KB, patch)
2016-06-03 10:43 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 16645: Plack: Add the multi_param fix from Context in koha.psgi (1.08 KB, patch)
2016-07-07 06:47 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2016-06-03 10:38:20 UTC

    
Comment 1 Marcel de Rooy 2016-06-03 10:43:51 UTC Comment hidden (obsolete)
Comment 2 Fridolin SOMERS 2016-07-06 15:04:55 UTC
Hie, 

I'd say it depends on Bug 15809 directly no ?
Comment 3 Fridolin SOMERS 2016-07-06 15:09:32 UTC
+ no warnings 'redefine'; 	
This is already set a few lines above.
No ?

+ use warnings 'redefine';
sure we need this line ?
Comment 4 Marcel de Rooy 2016-07-07 06:36:30 UTC
(In reply to Fridolin SOMERS from comment #2)
> Hie, 
> 
> I'd say it depends on Bug 15809 directly no ?

Yes it does. But that has been pushed some time ago already.
Comment 5 Marcel de Rooy 2016-07-07 06:46:29 UTC
(In reply to Fridolin SOMERS from comment #3)
> + no warnings 'redefine'; 	
> This is already set a few lines above.
> No ?
> 
> + use warnings 'redefine';
> sure we need this line ?

No warnings was repeated. Will remove it and move the enable warns one level higher outside the if statement. It is better to add it. Only allow redefines without warnings within the section you have explicitly marked as such.
Comment 6 Marcel de Rooy 2016-07-07 06:47:05 UTC
Created attachment 53161 [details] [review]
Bug 16645: Plack: Add the multi_param fix from Context in koha.psgi

When you are running koha.psgi (under Wheezy with an older CGI),
you will crash on multi_param calls (e.g. when searching in opac).

This patch simply copies the fix from Context to koha.psgi.

Test plan:
Run Plack with koha.psgi and test searching in opac.
Comment 7 Fridolin SOMERS 2016-07-07 07:15:35 UTC
Note that debian scripts work with plack only since jessie
Comment 8 Fridolin SOMERS 2016-07-07 07:57:20 UTC
I'm testing :

With the patch I get this warn :

Subroutine _input_cgi_parse redefined at /home/koha/src/opac/opac-search.pl line 527.

Is it plack-specific ?
Comment 9 Marcel de Rooy 2016-07-07 10:00:44 UTC
(In reply to Fridolin SOMERS from comment #8)
> I'm testing :
> 
> With the patch I get this warn :
> 
> Subroutine _input_cgi_parse redefined at /home/koha/src/opac/opac-search.pl
> line 527.
> 
> Is it plack-specific ?

I am not seeing it in my log btw. How can I reproduce?
Could be consequence of enabling the warnings again?
Comment 10 Fridolin SOMERS 2016-07-11 07:02:18 UTC
(In reply to Marcel de Rooy from comment #9)
> Could be consequence of enabling the warnings again?

I'd say yes
Comment 11 Marcel de Rooy 2016-11-16 12:56:25 UTC
Closing this report. We are not supporting Wheezy anymore and there is no interest in this patch.