Bug 16664 - SQL issues in 16.05 preventing installation in MySQL 5.7
Summary: SQL issues in 16.05 preventing installation in MySQL 5.7
Status: RESOLVED DUPLICATE of bug 16573
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (web-based installer) (show other bugs)
Version: 16.05
Hardware: All All
: P3 major (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-04 09:07 UTC by Robin Sheat
Modified: 2016-09-06 08:18 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16664: fix loaded SQL for strictness (1.94 KB, patch)
2016-06-04 09:09 UTC, Robin Sheat
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 16664: fix loaded SQL for strictness (1.99 KB, patch)
2016-07-06 02:41 UTC, Srdjan Jankovic
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Sheat 2016-06-04 09:07:28 UTC
The errors are:

[Sat Jun 4 11:00:03 2016] install.pl: DBD::mysql::st execute failed: BLOB, TEXT, GEOMETRY or JSON column 'defaultvalue' can't have a default value at /usr/share/perl5/DBIx/RunSQL.pm line 273. 

caused by:

  72   `defaultvalue` TEXT DEFAULT '',

---

[Sat Jun 4 10:56:57 2016] install.pl: DBD::mysql::st execute failed: Invalid default value for 'created_on' at /usr/share/perl5/DBIx/RunSQL.pm line 273. 

caused by:

2212   `created_on` TIMESTAMP NOT NULL, -- creation time

(timestamps are weird and special in mysql, see here: http://dev.mysql.com/doc/refman/5.7/en/timestamp-initialization.html )

---
Comment 1 Robin Sheat 2016-06-04 09:09:16 UTC Comment hidden (obsolete)
Comment 2 Robin Sheat 2016-06-04 09:10:00 UTC
To test:
* attempt to use the  web installer in Ubuntu 16.05, see that it works with this patch.
Comment 3 Srdjan Jankovic 2016-07-06 02:41:19 UTC
Created attachment 53119 [details] [review]
[SIGNED-OFF] Bug 16664: fix loaded SQL for strictness

There were some errors in the SQL structure that MySQL got upset at in
strict mode. This lets the file load.

Signed-off-by: Srdjan <srdjan@catalyst.net.nz>
Comment 4 Jonathan Druart 2016-07-06 15:12:18 UTC
This fix is already done on bug 16573 (which should get more love).
We could push this one separately anyway but I think the patch should fix existing installs too.
Comment 5 Jonathan Druart 2016-09-06 08:18:29 UTC

*** This bug has been marked as a duplicate of bug 16573 ***