Bug 16668 - Fix t/Ris.t (follow-up for 16442)
Summary: Fix t/Ris.t (follow-up for 16442)
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Test Suite (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Marcel de Rooy
URL:
Keywords:
: 16674 (view as bug list)
Depends on: 16442
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-05 19:06 UTC by Mirko Tietgen
Modified: 2017-12-07 22:18 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16668 - Move t/Ris.t to t/db_dependent/Ris.t (502 bytes, patch)
2016-06-05 19:07 UTC, Mirko Tietgen
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 16668 - Move t/Ris.t to t/db_dependent/Ris.t (550 bytes, patch)
2016-06-06 04:35 UTC, Srdjan Jankovic
Details | Diff | Splinter Review
Bug 16668: Fix t/Ris.t tests (1.46 KB, patch)
2016-06-07 11:30 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 16668: Fix t/Ris.t tests (1.56 KB, patch)
2016-06-07 12:12 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko Tietgen 2016-06-05 19:06:12 UTC
> DBI connect('database=koha;host=localhost;port=3306','kohaadmin',...) failed: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) at /usr/share/perl5/DBIx/Class/Storage/DBI.pm line 1249

Moving the test to db_dependent
Comment 1 Mirko Tietgen 2016-06-05 19:07:08 UTC Comment hidden (obsolete)
Comment 2 Srdjan Jankovic 2016-06-06 04:35:09 UTC Comment hidden (obsolete)
Comment 3 Marcel de Rooy 2016-06-06 08:17:21 UTC
Apart from some warnings generated from used modules, this test does not (yet) need the database. With some advanced mocking you might get rid of them. If you just point KOHA_CONF to the original clone's koha-conf, you will have no warnings (and no db access).
Comment 4 Jonathan Druart 2016-06-07 11:30:55 UTC Comment hidden (obsolete)
Comment 5 Marcel de Rooy 2016-06-07 12:12:29 UTC
Created attachment 52124 [details] [review]
Bug 16668: Fix t/Ris.t tests

Caused by bug 16442.
Now we need to mock the marcflavour pref

Test plan:
  prove t/Ris.t
should return green

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 6 Marcel de Rooy 2016-06-07 12:16:42 UTC
Taking the liberty to set to PQA: trivial fix for 16442 just pushed.
Comment 7 Jonathan Druart 2016-06-10 13:30:07 UTC
*** Bug 16674 has been marked as a duplicate of this bug. ***
Comment 8 Kyle M Hall 2016-06-10 17:00:08 UTC
Pushed to master for 16.11, thanks Jonathan!
Comment 9 Frédéric Demians 2016-06-15 07:43:40 UTC
Pushed in 16.05. Will be in 16.05.01.
Comment 10 Julian Maurice 2016-06-16 08:59:23 UTC
Patch pushed to 3.22.x, will be in 3.22.8