Bug 16680 - Library name are not displayed for holds in transit
Summary: Library name are not displayed for holds in transit
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 13918
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-07 09:47 UTC by Jonathan Druart
Modified: 2019-06-27 09:24 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16680: (bug 13918 follow-up) Display library names for holds in transit (2.36 KB, patch)
2016-06-07 09:50 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 16680: (bug 13918 follow-up) Display library names for holds in transit (2.41 KB, patch)
2016-06-07 15:53 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 16680: (bug 13918 follow-up) Display library names for holds in transit (2.48 KB, patch)
2016-06-19 13:53 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-06-07 09:47:17 UTC
Introduced by bug 13918

From the logs:
No method wbrname! at /home/koha/src/koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-user.tt line 603.
No method wbrcd! at /home/koha/src/koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-user.tt line 603.
Comment 1 Jonathan Druart 2016-06-07 09:50:01 UTC Comment hidden (obsolete)
Comment 2 Marc Véron 2016-06-07 12:36:08 UTC
I note this here because it might be related:
 opac-user.pl: No method frombranch! at /usr/share/kohaclone/koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-user.tt line 607

In OPAC I get "Item in transit from since"
(with and without this patch)
Comment 3 Jonathan Druart 2016-06-07 14:41:32 UTC
(In reply to Marc Véron from comment #2)
> I note this here because it might be related:
>  opac-user.pl: No method frombranch! at
> /usr/share/kohaclone/koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-user.tt
> line 607
> 
> In OPAC I get "Item in transit from since"
> (with and without this patch)

Yes it's related to bug 13918 as well, but I don't know how to fix it easily and Kyle may have fixed it already somewhere else. Could you please open another bug report and link it to 13918?
Comment 4 Marc Véron 2016-06-07 14:58:05 UTC
(In reply to Jonathan Druart from comment #3)
> (In reply to Marc Véron from comment #2)
> > I note this here because it might be related:
> >  opac-user.pl: No method frombranch! at
> > /usr/share/kohaclone/koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-user.tt
> > line 607
> > 
> > In OPAC I get "Item in transit from since"
> > (with and without this patch)
> 
> Yes it's related to bug 13918 as well, but I don't know how to fix it easily
> and Kyle may have fixed it already somewhere else. Could you please open
> another bug report and link it to 13918?

See Bug 16686 - Fix "Item in transit from since" in Holds tab
Comment 5 Kyle M Hall 2016-06-07 15:53:03 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2016-06-19 13:53:51 UTC
Created attachment 52544 [details] [review]
[PASSED QA] Bug 16680: (bug 13918 follow-up) Display library names for holds in transit

Regression introduced by bug 13918: the library names are not displayed
anymore for holds in transit.
They are 2 warns in the logs:
No method wbrname! at
/home/koha/src/koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-user.tt
line 603.
No method wbrcd! at
/home/koha/src/koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-user.tt
line 603.

Test plan:
Make sure you have holds in transit and go the opac-user.pl
In the "Holds" tab, you should see "Item in transit to LIBRARY NAME"

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Kyle M Hall 2016-06-24 11:48:23 UTC
Pushed to master for 16.11,t thanks Jonathan!
Comment 8 Frédéric Demians 2016-08-01 11:49:47 UTC
Pushed in 16.05. Will be in 16.05.02.
Comment 9 Julian Maurice 2016-08-16 12:26:16 UTC
Not needed in 3.22.x