Bug 16724 - Link from online help to manual broken (as of version 16.05)
Summary: Link from online help to manual broken (as of version 16.05)
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 11238
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-13 16:36 UTC by Marc Véron
Modified: 2017-12-07 22:15 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16724: Fix link to the online documentation links (919 bytes, patch)
2016-06-13 17:22 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 16724 - Link from online help to manual broken (as of version 16.05) (1.21 KB, patch)
2016-06-13 17:40 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 16724: Fix link to the online documentation links (976 bytes, patch)
2016-06-13 17:45 UTC, Mirko Tietgen
Details | Diff | Splinter Review
[PASSED QA] Bug 16724: Fix link to the online documentation links (1.02 KB, patch)
2016-06-19 12:00 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Véron 2016-06-13 16:36:51 UTC
In Koha version 16.05, the links from the online help to koha manual are broken.

To reproduce: In staff client (e.g. About page), click on 'Help' at the top right af the screen.
Then click on link 'manual' in "See the full documentation for the About page in the manual (online)."

Result:
For 16.05:
http://manual.koha-community.org/16.4/en/aboutkoha.html
The requested URL /16.4/en/aboutkoha.html was not found on this server.

For current master (16.06.00.002):
http://manual.koha-community.org/16.06/en/aboutkoha.html
The requested URL /16.06/en/aboutkoha.html was not found on this server.

The correct link should be (for both):
The requested URL /16.05/en/aboutkoha.html was not found on this server.
Comment 1 Marc Véron 2016-06-13 16:41:38 UTC
Note: Version number for help files is calculated in help.pl line 68 ff
Comment 2 Marc Véron 2016-06-13 17:03:50 UTC
Calculation was introduced for 3.14.x ( by Bug 11238 - The version of the manual online link should be dynamically updated ).
Comment 3 Jonathan Druart 2016-06-13 17:22:01 UTC Comment hidden (obsolete)
Comment 4 Mirko Tietgen 2016-06-13 17:40:03 UTC Comment hidden (obsolete)
Comment 5 Mirko Tietgen 2016-06-13 17:45:53 UTC Comment hidden (obsolete)
Comment 6 Marc Véron 2016-06-13 18:20:15 UTC
It displays OK with 16.05 and 16.06, but what about future versions?

E.g. 16.07, 16.08 (will result in a link to http://manual.koha-community.org/16.07/en/ ) and 16.09, 16.10 (will result in a link to http://manual.koha-community.org/16.09/en/
Comment 7 Katrin Fischer 2016-06-13 18:22:02 UTC
The numbers for stable should always be .05 and .11 (may and november) currently - so that might work ok.
Comment 8 Mark Tompsett 2016-06-16 00:40:27 UTC
Comment on attachment 52341 [details] [review]
Bug 16724: Fix link to the online documentation links

Review of attachment 52341 [details] [review]:
-----------------------------------------------------------------

::: help.pl
@@ +69,5 @@
>  if ( $help_version =~ m|^(\d+)\.(\d{2}).*$| ) {
>      my $version = $1;
>      my $major = $2;
> +    unless ( $major % 2 ) { $major-- };
> +    $major = sprintf("%02d", $major);

Why not put the sprintf on the next line and remove the interpolation too? :)
This works too, though.
Comment 9 Jonathan Druart 2016-06-18 13:16:20 UTC
(In reply to M. Tompsett from comment #8)
> Comment on attachment 52341 [details] [review] [review]
> Bug 16724: Fix link to the online documentation links
> 
> Review of attachment 52341 [details] [review] [review]:
> -----------------------------------------------------------------
> 
> ::: help.pl
> @@ +69,5 @@
> >  if ( $help_version =~ m|^(\d+)\.(\d{2}).*$| ) {
> >      my $version = $1;
> >      my $major = $2;
> > +    unless ( $major % 2 ) { $major-- };
> > +    $major = sprintf("%02d", $major);
> 
> Why not put the sprintf on the next line and remove the interpolation too? :)
> This works too, though.

I don't understand. Do you suggest
  $help_version = $version . '.' . sprintf("%02d", $major);
?
Comment 10 Katrin Fischer 2016-06-19 12:00:18 UTC
Created attachment 52539 [details] [review]
[PASSED QA] Bug 16724: Fix link to the online documentation links

Since the numbering changes, the online doc links are broken.

Test plan:
Make sure the online doc links work on the help pages.

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 11 Kyle M Hall 2016-06-24 12:00:49 UTC
Pushed to master for Koha 16.11, thanks Jonathan!
Comment 12 Frédéric Demians 2016-08-01 11:51:24 UTC
Pushed in 16.05. Will be in 16.05.02.
Comment 13 Julian Maurice 2016-08-16 12:46:05 UTC
Not needed in 3.22.x