Bug 16746 - Can not find duplicated authorities cataloguing a new one
Summary: Can not find duplicated authorities cataloguing a new one
Status: RESOLVED DUPLICATE of bug 19415
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Juan Romay Sieira
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-15 15:32 UTC by Juan Romay Sieira
Modified: 2017-11-01 16:36 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Patch to solve this issue (1.09 KB, patch)
2016-06-15 15:36 UTC, Juan Romay Sieira
Details | Diff | Splinter Review
Bug 16746: Proposed start of counter-patch (2.57 KB, patch)
2016-06-25 04:22 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 16746: Proposed start of counter-patch (2.50 KB, patch)
2016-06-25 04:27 UTC, M. Tompsett
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Romay Sieira 2016-06-15 15:32:02 UTC
Can not find duplicated authorities cataloguing a new one, due to the new version of SimpleSearch
Comment 1 Juan Romay Sieira 2016-06-15 15:36:44 UTC
Created attachment 52440 [details] [review]
Patch to solve this issue
Comment 2 Juan Romay Sieira 2016-06-15 15:39:02 UTC
1. Add a new authority that exists in your authority server, Koha will now find none.

2. Apply the patch

3. Add a new authority that exists in your authority server, Koha will find similar authorities in your catalogue
Comment 3 M. Tompsett 2016-06-24 14:39:25 UTC
Comment on attachment 52440 [details] [review]
Patch to solve this issue

Review of attachment 52440 [details] [review]:
-----------------------------------------------------------------

::: C4/AuthoritiesMarc.pm
@@ +829,4 @@
>          }
>      }
>      my $searcher = Koha::SearchEngine::Search->new({index => $Koha::SearchEngine::AUTHORITIES_INDEX});
> +    my ($error, $results, $total_hits) = $searcher->simple_search_compat( $query, 0, 1, [ "authorityserver" ]);

I don't think this is the correct solution, as ElasticSearch and Zebra both implement simple_search_compat, but ElasticSearch does not take the fourth parameter. Instead, it uses the objects 'index' accessor, which the Zebra version seems to be missing. Counter patch to follow today.
Comment 4 M. Tompsett 2016-06-24 19:28:33 UTC
I have something which does this problem, but there seems to be a larger issue.
Comment 5 M. Tompsett 2016-06-25 04:22:34 UTC Comment hidden (obsolete)
Comment 6 M. Tompsett 2016-06-25 04:27:40 UTC
Created attachment 52870 [details] [review]
Bug 16746: Proposed start of counter-patch

This is the beginning of a counter patch.
Feel free to apply it and test it, Juan Romay Sieira.
However, please expand the test plan to be more
detailed:

-- type X into field Y
-- click button Z
-- click downdrop W
-- select item V
-- enter 'text' into text box labelled A

"Add a new authority that exists in your
 authority server, Koha will now find none."
is not detailed enough for a person unfamiliar with the
interface.

Feel free to apply 16809 first. :)
Comment 7 Josef Moravec 2016-12-09 11:44:42 UTC
(In reply to M. Tompsett from comment #6)
> Created attachment 52870 [details] [review] [review]
> Bug 16746: Proposed start of counter-patch
> 
> This is the beginning of a counter patch.
> Feel free to apply it and test it, Juan Romay Sieira.
> However, please expand the test plan to be more
> detailed:
> 
> -- type X into field Y
> -- click button Z
> -- click downdrop W
> -- select item V
> -- enter 'text' into text box labelled A
> 
> "Add a new authority that exists in your
>  authority server, Koha will now find none."
> is not detailed enough for a person unfamiliar with the
> interface.
> 
> Feel free to apply 16809 first. :)

Are you going to continue on this?
Comment 8 Nick Clemens 2017-11-01 16:36:43 UTC

*** This bug has been marked as a duplicate of bug 19415 ***