Bug 16798 - automatic_renewals.pl should run before overdues and fines are generated
Summary: automatic_renewals.pl should run before overdues and fines are generated
Status: RESOLVED DUPLICATE of bug 11144
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Target Milestone: ---
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-22 11:28 UTC by Kyle M Hall
Modified: 2016-06-22 20:34 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16798 - automatic_renewals.pl should run before overdues and fines are generated (2.03 KB, patch)
2016-06-22 11:31 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2016-06-22 11:28:02 UTC
Unless an auto_renew item's circ rule has a "no renewal before" line set, it will only auto-renew at the point where the item is technically overdue. However, automatic_renewal.pl in etc/cron.daily/koha-common is set to run *after* all those cronjobs!
Comment 1 Kyle M Hall 2016-06-22 11:31:43 UTC
Created attachment 52679 [details] [review]
Bug 16798 - automatic_renewals.pl should run before overdues and fines are generated

Unless an auto_renew item's circ rule has a "no renewal before" line
set, it will only auto-renew at the point where the item is technically
overdue. However, automatic_renewal.pl in etc/cron.daily/koha-common is
set to run *after* all those cronjobs!

Test Plan:
1) On a package installation, set up an item to auto_renew with no
   "no renewal before" rule.
2) On the morning it is autorenewed it should also have a fine
3) Change the cronjob order to that of this patch
4) Repeat step 1
5) On the morning it is autorenewed it should not have a fine
Comment 2 Katrin Fischer 2016-06-22 20:34:04 UTC

*** This bug has been marked as a duplicate of bug 11144 ***