Bug 16802 - Linking to a new authority does not clear subfields appropriately
Summary: Linking to a new authority does not clear subfields appropriately
Status: CLOSED DUPLICATE of bug 17908
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-23 15:45 UTC by Nick Clemens
Modified: 2017-01-14 12:01 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2016-06-23 15:45:32 UTC
If you have a 700 heading containing some subfields (d,q,r) and link to an authority not containing those fields they remain in the record after linking and when the record is saved

To reproduce:
Have/create a record with a 700 field containing extar subfields
Link to an authority without those subfields
The extra subfields remain
Save the record
Extra subfields are saved and things now don't match up.
Comment 1 Nick Clemens 2016-06-23 15:46:17 UTC
Adding two possibly related bugs as see also
Comment 2 Marcel de Rooy 2017-01-14 12:01:20 UTC
Closing this one in favor of bugs under omnibus bug 17908.
Could be 5572/11315/14583

*** This bug has been marked as a duplicate of bug 17908 ***