Bug 16858 - import_borrowers.pl does not load because of mysql 5.7
Summary: import_borrowers.pl does not load because of mysql 5.7
Status: RESOLVED DUPLICATE of bug 21596
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All Linux
: P5 - low major (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks: 17258
  Show dependency treegraph
 
Reported: 2016-07-06 09:42 UTC by zefanja
Modified: 2018-10-24 16:37 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zefanja 2016-07-06 09:42:15 UTC
The Import Patrons tool does not load on MySQL 5.7 because of the default sql_mode: only_full_group_by.

This is the error I got: http://paste.koha-community.org/16

Can't use an undefined value as an ARRAY reference at /usr/lib/x86_64-linux-gnu/perl5/5.22/DBI.pm line 2083

If I change the sql_mode to a mysql 5.6 behavior the import page loads fine.
Comment 1 Jonathan Druart 2018-10-24 16:37:54 UTC
This should have been fixed by bug 21596.

*** This bug has been marked as a duplicate of bug 21596 ***