Bug 16908 - Koha::Patrons - Remove GetSortDetails
Summary: Koha::Patrons - Remove GetSortDetails
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Marcel de Rooy
URL:
Keywords:
Depends on:
Blocks: 16846 18512
  Show dependency treegraph
 
Reported: 2016-07-12 18:10 UTC by Jonathan Druart
Modified: 2017-12-07 22:21 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 16908: Koha::Patrons - Remove GetSortDetails (5.14 KB, patch)
2016-07-12 18:13 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 16908: Koha::Patrons - Remove GetSortDetails (5.24 KB, patch)
2016-07-18 13:21 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 16908: Koha::Patrons - Remove GetSortDetails (5.29 KB, patch)
2016-09-02 11:39 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 16908: Remove non-desired export line (655 bytes, patch)
2016-11-07 15:06 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-07-12 18:10:03 UTC
This subroutine is only used in one script and its job is the same as GetAuthorisedValueByCode.
It's better to use the AuthorisedValues TT plugin to retrieve descriptions.
Comment 1 Jonathan Druart 2016-07-12 18:13:23 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2016-07-18 13:21:48 UTC Comment hidden (obsolete)
Comment 3 Marcel de Rooy 2016-09-02 11:39:52 UTC
Created attachment 55112 [details] [review]
Bug 16908: Koha::Patrons - Remove GetSortDetails

This subroutine was only used in one script and its job is the same as
GetAuthorisedValueByCode.
It's better to use the AuthorisedValues TT plugin to retrieve AV
descriptions.

Test plan:
Edit a patron with sort1 and/or sort2 defined.
On the patron details page (members/moremember.pl) you should see the
sort1 and/or sort2 info displayed.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 4 Kyle M Hall 2016-09-09 14:15:37 UTC
Pushed to master for 16.11, thanks Jonathan!
Comment 5 Jonathan Druart 2016-11-07 15:06:58 UTC
Created attachment 57268 [details] [review]
Bug 16908: Remove non-desired export line

GetTitles has been removed by bug 16847 and reintroduced it by bug
16908, caused by a bad merge conflict.
Comment 6 Jonathan Druart 2016-11-07 15:07:34 UTC
It seems that Marcel reintroduced a deleted line when rebasing this patch. Kyle could you push this follow-up please?