Bug 17046 - t/Creators.t kills master packages
Summary: t/Creators.t kills master packages
Status: RESOLVED DUPLICATE of bug 15200
Alias: None
Product: Koha
Classification: Unclassified
Component: Test Suite (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Chris Cormack
QA Contact: Galen Charlton
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-04 07:10 UTC by Mirko Tietgen
Modified: 2016-08-08 12:16 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko Tietgen 2016-08-04 07:10:37 UTC
debian/build-git-snapshot on master dies because of t/Creators.t:

ERROR in koha-conf.xml -- missing <font type="H">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
ERROR in koha-conf.xml -- missing <font type="H">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.

#   Failed test 'testing StrWidth() returns correct point width'
#   at t/Creators.t line 55.
#          got: '19.344'
#     expected: '23.044921875'

#   Failed test 'testing Text() writes to the correct x-value'
#   at t/Creators.t line 59.
#          got: '29.344'
#     expected: '33.044921875'
ERROR in koha-conf.xml -- missing <font type="TR">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
ERROR in koha-conf.xml -- missing <font type="TB">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
ERROR in koha-conf.xml -- missing <font type="TI">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
ERROR in koha-conf.xml -- missing <font type="TBI">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
ERROR in koha-conf.xml -- missing <font type="C">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
ERROR in koha-conf.xml -- missing <font type="CB">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
ERROR in koha-conf.xml -- missing <font type="CO">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
ERROR in koha-conf.xml -- missing <font type="CBO">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
ERROR in koha-conf.xml -- missing <font type="H">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
ERROR in koha-conf.xml -- missing <font type="HO">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
ERROR in koha-conf.xml -- missing <font type="HB">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
ERROR in koha-conf.xml -- missing <font type="HBO">/path/to/font.ttf</font> at /build/koha-16.06~nightly+20160804085200.4a70dc58/blib/PERL_MODULE_DIR/C4/Creators/PDF.pm line 120.
Wide character in compress at /usr/share/perl5/PDF/Reuse.pm line 820.
# Looks like you planned 41 tests but ran 39.
# Looks like you failed 2 tests of 39 run.
# Looks like your test exited with 25 just after 39.
t/Creators.t ........................ 
Dubious, test returned 25 (wstat 6400, 0x1900)
Failed 4/41 subtests
Comment 1 Mirko Tietgen 2016-08-08 12:16:36 UTC

*** This bug has been marked as a duplicate of bug 15200 ***