Bug 17048 - Authority search result list page scrolling not working properly
Summary: Authority search result list page scrolling not working properly
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
: 17192 17370 (view as bug list)
Depends on: 2735 12478
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-04 09:06 UTC by Iming Chan
Modified: 2019-06-27 09:24 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Record 1-20 (Page 1) (218.60 KB, image/jpeg)
2016-08-04 09:06 UTC, Iming Chan
Details
Record 21-40 (Page 2) -- Actual: Record 2-21 (221.12 KB, image/jpeg)
2016-08-04 09:07 UTC, Iming Chan
Details
Record 41 (Page 3) -- Actual: Record 3-22 (222.08 KB, image/jpeg)
2016-08-04 09:09 UTC, Iming Chan
Details
Bug 17048: Fix pagination offset for authority searches (2.38 KB, patch)
2016-08-19 13:40 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 17048: Fix pagination offset for authority searches (2.45 KB, patch)
2016-08-23 23:09 UTC, Aleisha Amohia
Details | Diff | Splinter Review
[PASSED QA] Bug 17048: Fix pagination offset for authority searches (2.50 KB, patch)
2016-08-28 19:13 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Iming Chan 2016-08-04 09:06:33 UTC
Created attachment 53988 [details]
Record 1-20 (Page 1)

Authority search result list page scrolling not working properly.  The ">" (single right arrow) doesn't start from the end of previous page.  

For example, after displayed record 1-20. Click ">", you should get record 21-40, but, it actually showing record 2-21!  See screen shots attached.
Comment 1 Iming Chan 2016-08-04 09:07:55 UTC
Created attachment 53989 [details]
Record 21-40 (Page 2) -- Actual: Record 2-21
Comment 2 Iming Chan 2016-08-04 09:09:11 UTC
Created attachment 53990 [details]
Record 41 (Page 3) -- Actual: Record 3-22
Comment 3 Jonathan Druart 2016-08-19 13:07:40 UTC
It looks like it has been introduced by bug 12478
Comment 4 Jonathan Druart 2016-08-19 13:22:58 UTC
Same at the OPAC, because of bug 2735.
Comment 5 Jonathan Druart 2016-08-19 13:40:18 UTC Comment hidden (obsolete)
Comment 6 Aleisha Amohia 2016-08-22 22:52:52 UTC
I cannot reproduce the bug. Can someone check to see if this patch is still necessary?
Comment 7 Jonathan Druart 2016-08-23 09:34:52 UTC
(In reply to Aleisha Amohia from comment #6)
> I cannot reproduce the bug. Can someone check to see if this patch is still
> necessary?

Yes it is. Did you see the screenshots? They explain very well the issue.
Comment 8 Aleisha Amohia 2016-08-23 23:09:17 UTC Comment hidden (obsolete)
Comment 9 Aleisha Amohia 2016-08-23 23:09:53 UTC
(In reply to Jonathan Druart from comment #7)
> Yes it is. Did you see the screenshots? They explain very well the issue.

You're right sorry, I was trying to reproduce it in the wrong place. Tested in the right place this time and patch works well. :)
Comment 10 Aleisha Amohia 2016-08-26 03:07:47 UTC
*** Bug 17192 has been marked as a duplicate of this bug. ***
Comment 11 Katrin Fischer 2016-08-28 19:13:53 UTC
Created attachment 54955 [details] [review]
[PASSED QA] Bug 17048: Fix pagination offset for authority searches

At the intranet, the pagination has been broken by bug 12478 (Elastic
Search). There was a confusion between the offset and the page number.

At the OPAC, it is broken since bug 2735 which has mimicked the intranet
script.

Test plan:
Search for a term which will return more than 1 page of results.
Click on the second page
=> Without this patch, the first result of the second page is the second
result of the first page
=> With this patch applied, the offset will be corrected

Signed-off-by: Aleisha Amohia <aleishaamohia@hotmail.com>

Signed-off-by: Katrin Fischer  <katrin.fischer@bsz-bw.de>
Comment 12 Kyle M Hall 2016-09-02 14:50:11 UTC
Pushed to master for 16.11, thanks Jonathan!
Comment 13 Frédéric Demians 2016-09-08 19:14:55 UTC
Pushed in 16.05. Will be in 16.05.04.
Comment 14 Bouzid Fergani 2016-09-28 19:50:52 UTC
*** Bug 17370 has been marked as a duplicate of this bug. ***
Comment 15 Héctor Eduardo Castro Avalos 2018-10-09 20:18:46 UTC
This problem persist in master and 18.05
Comment 16 Jonathan Druart 2018-10-09 20:50:34 UTC
(In reply to Héctor Eduardo Castro Avalos from comment #15)
> This problem persist in master and 18.05

Please open a new bug report (linked to this one), provide the exact version you are using as well as the search engine you are using (zebra/es).