Bug 17177 - [3.20.x] Can't locate Koha/Config/SysPrefs.pm in @INC on intranet about page
Summary: [3.20.x] Can't locate Koha/Config/SysPrefs.pm in @INC on intranet about page
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: About (show other bugs)
Version: 3.20
Hardware: All All
: P3 major (vote)
Assignee: Chris Cormack
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-24 00:26 UTC by Liz Rea
Modified: 2019-06-27 09:24 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17177 - about.pl references a module that doesn't exist (631 bytes, patch)
2016-08-24 00:54 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 17177 - about.pl references a module that doesn't exist (705 bytes, patch)
2016-08-24 11:01 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2016-08-24 00:26:05 UTC
From 3.20.11 going to the intranet About page will cause this error:

Can't locate Koha/Config/SysPrefs.pm in @INC (@INC contains: /usr/share/koha/lib /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /usr/share/koha/intranet/cgi-bin/about.pl line 38.

Seems to have been introduced by f49adba138c7deb6736c50a75e1863b1d4647669 and only a problem, I think, in the 3.20 line.
Comment 1 Chris Cormack 2016-08-24 00:54:37 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2016-08-24 11:01:31 UTC
Created attachment 54812 [details] [review]
Bug 17177 - about.pl references a module that doesn't exist

To test
1/ Go to the about page, notice error
2/ Apply patch
3/ Notice error gone

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
caused by a bad merge conflict with bug 12721 when backporting it to 3.20.x
Comment 3 Jonathan Druart 2016-08-24 11:02:01 UTC
Skipping QA.
Comment 4 Jonathan Druart 2016-10-14 10:30:09 UTC
Brendan, this patch is for 3.20. Switching back to PQA.
Comment 5 Marcel de Rooy 2017-01-19 11:14:39 UTC
I am changing the status of this patch. It is aimed for 3.20 only. But I do NOT see it in that branch. As far as I know, nobody maintains the version anymore?

No use to keep it in the PQA queue for master. Setting the status to Stable, just as if it had been pushed to 3.22. So, the RMaint for 3.20.x should act now ;)