Bug 17224 - Switch to Koha::Cache completely in Context.pm ?
Summary: Switch to Koha::Cache completely in Context.pm ?
Status: RESOLVED DUPLICATE of bug 11921
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-30 13:55 UTC by Marcel de Rooy
Modified: 2016-09-14 10:34 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2016-08-30 13:55:53 UTC
Context.pm creates a cache with Cache::Memcached while Koha::Cache uses Cache::Memcached::Fast. (And Context even uses a cache from Koha::Cache too!)

While adding Cache::Memcached to PerlDependencies on the see also report, we should probably fix Context somehow to use Koha::Cache completely.
Note that Fast does not support the parameters debug and expire_time as used in Context now.
Comment 1 Jonathan Druart 2016-08-30 15:36:35 UTC
It's on my todo list, but I'd like to see bug 16579 pushed first.
Comment 2 Jonathan Druart 2016-09-14 10:34:31 UTC
This has been done by Bug 11921: Restore memcached infos to koha-conf

*** This bug has been marked as a duplicate of bug 11921 ***