Bug 17285 - Rancor - Advanced editor fails or broken
Summary: Rancor - Advanced editor fails or broken
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 15758
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-09 18:11 UTC by Héctor Eduardo Castro Avalos
Modified: 2019-06-27 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17285: (15758 follow-up) Fix advanced editor (1.15 KB, patch)
2016-09-12 15:48 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 17285: (15758 follow-up) Fix advanced editor (1.26 KB, patch)
2016-09-12 16:08 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 17285: (15758 follow-up) Fix advanced editor (1.30 KB, patch)
2016-09-12 16:18 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Héctor Eduardo Castro Avalos 2016-09-09 18:11:27 UTC
When you try to create or modify a record with the "Advanced editor", the screen is forzen in the message "Loading, please wait"

IRC Comment with oleonard:

>"git bisect says the cause is Bug 15758"
>"Specifically, commit df97814"
Comment 1 Owen Leonard 2016-09-09 18:14:34 UTC
> >"git bisect says the cause is Bug 15758"
> >"Specifically, commit df97814"

The error is in svc/cataloguing/framework?callback=define
Comment 2 Jonathan Druart 2016-09-12 15:48:22 UTC Comment hidden (obsolete)
Comment 3 Héctor Eduardo Castro Avalos 2016-09-12 16:08:12 UTC Comment hidden (obsolete)
Comment 4 Nick Clemens 2016-09-12 16:18:53 UTC
Created attachment 55510 [details] [review]
Bug 17285: (15758 follow-up) Fix advanced editor

Little mistake from df97814, $branches is a hash { branchcode =>
branchname }

Test plan:
Edit a biblio with the advanced editor

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
The advanced editor works as expected

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 5 Kyle M Hall 2016-09-12 16:33:31 UTC
Pushed to master for 16.11, thanks Jonathan!