Bug 17325 - Circulation needs borrowers permission if patrons got image
Summary: Circulation needs borrowers permission if patrons got image
Status: RESOLVED DUPLICATE of bug 17423
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Fridolin Somers
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-21 13:32 UTC by Sophie MEYNIEUX
Modified: 2016-10-11 08:09 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sophie MEYNIEUX 2016-09-21 13:32:33 UTC
Log in with an account having circulate_remaining_permissions and staffaccess.

Find a patron with image. Try to check out for this patron.
Patron image is not loaded and when you give barcode to check out, you are disconnected from Koha.

Give borrowers permission to your account.
Try to checkout for the same patron as before. Patron image is correctly displaid and check out is done correctly.

This is because to display patron info, koha/members/patronimage.pl is called that needs borrowers permission.

This is a problem when you want an account only for circulation and not patron modification.
Comment 1 Fridolin Somers 2016-10-11 08:09:40 UTC

*** This bug has been marked as a duplicate of bug 17423 ***