Bug 17334 - members-update.pl should show timestamp
Summary: members-update.pl should show timestamp
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Alex Buckley
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-23 14:33 UTC by Christopher Brannon
Modified: 2017-10-27 14:53 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 17334- Added a timestamp to the members-update.tt To show the user when the pending modifications were requested. (2.80 KB, patch)
2017-01-20 04:11 UTC, Alex Buckley
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 17334- Added a timestamp to the members-update.tt To show the user when the pending modifications were requested. (2.87 KB, patch)
2017-01-20 15:08 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 17334: Format the date according to the system preference (2.38 KB, patch)
2017-01-26 11:45 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 17334- Added a timestamp to the members-update.tt To show the user when the pending modifications were requested. (2.85 KB, patch)
2017-01-26 11:46 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 17334: Format the date according to the system preference (2.38 KB, patch)
2017-01-26 11:46 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 17334 - Second update following QA feedback (2.65 KB, patch)
2017-01-26 19:23 UTC, Alex Buckley
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 17334: Format the date according to the system preference (2.45 KB, patch)
2017-01-30 16:19 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 17334- Added a timestamp to the members-update.tt To show the user when the pending modifications were requested. (2.92 KB, patch)
2017-01-31 10:23 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 17334: Format the date according to the system preference (2.51 KB, patch)
2017-01-31 10:23 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Brannon 2016-09-23 14:33:33 UTC
In the management of patron updates, it seems logical that the requests should show the timestamp of when the request was placed.  Yes, you can look this up in a report, but this should be a basic feature of managing requests.

Ideally, it should show on the same line as the patron name.  Probably something like "Requested: 2016-09-05"
Comment 1 Alex Buckley 2017-01-20 04:11:34 UTC Comment hidden (obsolete)
Comment 2 M. Tompsett 2017-01-20 15:08:53 UTC Comment hidden (obsolete)
Comment 3 Alex Buckley 2017-01-25 20:19:53 UTC
(in reply to comment 2 by M.Tompsett)

I have altered the formatting of the date so that it does not show time, i.e. it is displayed in the format:
DD/MM/YY

I assume this is what you were referring to when saying that TT variable was excessive?

But before I attach my new commit to this bug, I would like to ask if you are happy with the time being displayed being the UTC rather than the localtime?

The issue is that the timestamp of the member modification request is stored as UTC in the database
Comment 4 M. Tompsett 2017-01-26 04:54:10 UTC Comment hidden (obsolete)
Comment 5 M. Tompsett 2017-01-26 04:55:26 UTC
(In reply to Alex Buckley from comment #3)
> But before I attach my new commit to this bug...

No need. Let QA do their job. If they are fine with it. Let it go.
If not, they'll tweak it and push it through.
Comment 6 Jonathan Druart 2017-01-26 11:45:09 UTC Comment hidden (obsolete)
Comment 7 Jonathan Druart 2017-01-26 11:46:06 UTC
Created attachment 59575 [details] [review]
Bug 17334- Added a timestamp to the members-update.tt To show the user when the pending modifications were requested.

Test plan:
1.Log into OPAC and click on Lists->Your Lists->your personal details

2. Change/add a value in that form

3. Select the 'Submit update request'

4. Log into the Koha staff interface, then go to the url:
cgi-bin/koha/members/members-update.pl

5. You will see near the top of each box containing a pending request the following are displayed: surname, firstname,
    patron category, branch, and cardnumber but no timestamp.

6. Apply this patch

7. Repeat steps 1,2, 3, 4

8. You will now see timestamp in the format "Requested: YYYY-MM-DD
HH:MM:SS" next to each patrons details near the top of each pending
request box.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>
Comment 8 Jonathan Druart 2017-01-26 11:46:11 UTC
Created attachment 59576 [details] [review]
Bug 17334: Format the date according to the system preference

- Use KohaDates TT plugin to format the date correctly
- Do not use a temporary variable
- Replace:
    patron's info Requested: Datetime
  with
    patron's info - Requested on Datetime
Comment 9 Jonathan Druart 2017-01-26 11:46:34 UTC
I'd like to get a signoff on the second patch.
Is the display better?
Comment 10 Alex Buckley 2017-01-26 19:23:29 UTC Comment hidden (obsolete)
Comment 11 Alex Buckley 2017-01-26 19:28:49 UTC
(in reply to Jonathan Druart)

Sorry I realised you have made all of the neccisary changes and so to remove my second patch ( Bug 17334 - Second update following QA feedback) can I just set it to obsolete?
Comment 12 Alex Buckley 2017-01-26 19:33:09 UTC
I am still learning bugzilla and didn't realise your patch contained the necessary changes. so sorry about that
Comment 13 Owen Leonard 2017-01-30 16:19:39 UTC
Created attachment 59658 [details] [review]
[SIGNED-OFF] Bug 17334: Format the date according to the system preference

- Use KohaDates TT plugin to format the date correctly
- Do not use a temporary variable
- Replace:
    patron's info Requested: Datetime
  with
    patron's info - Requested on Datetime

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 14 Jonathan Druart 2017-01-31 10:23:36 UTC
Created attachment 59677 [details] [review]
Bug 17334- Added a timestamp to the members-update.tt To show the user when the pending modifications were requested.

Test plan:
1.Log into OPAC and click on Lists->Your Lists->your personal details

2. Change/add a value in that form

3. Select the 'Submit update request'

4. Log into the Koha staff interface, then go to the url:
cgi-bin/koha/members/members-update.pl

5. You will see near the top of each box containing a pending request the following are displayed: surname, firstname,
    patron category, branch, and cardnumber but no timestamp.

6. Apply this patch

7. Repeat steps 1,2, 3, 4

8. You will now see timestamp in the format "Requested: YYYY-MM-DD
HH:MM:SS" next to each patrons details near the top of each pending
request box.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 15 Jonathan Druart 2017-01-31 10:23:40 UTC
Created attachment 59678 [details] [review]
Bug 17334: Format the date according to the system preference

- Use KohaDates TT plugin to format the date correctly
- Do not use a temporary variable
- Replace:
    patron's info Requested: Datetime
  with
    patron's info - Requested on Datetime

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 16 Kyle M Hall 2017-03-03 17:52:02 UTC
Pushed to master for 17.05, thanks Alex!
Comment 17 Katrin Fischer 2017-03-12 22:51:37 UTC
This won't get ported back to 16.11.x as it is an enhancement.
Comment 18 Kelly McElligott 2017-10-26 18:11:35 UTC
Could this be used when a Patron makes a purchase suggestion also?  A library has mentioned that they would love to see the time in addition to the date on purchase suggestions made through the OPAC?

Thanks!
Comment 19 Christopher Brannon 2017-10-27 14:53:40 UTC
(In reply to Kelly McElligott from comment #18)
> Could this be used when a Patron makes a purchase suggestion also?  A
> library has mentioned that they would love to see the time in addition to
> the date on purchase suggestions made through the OPAC?
> 
> Thanks!

That is a separate matter.  A new bug should be submitted for that feature.  :)