Bug 17389 - Exporting framework always export the default framework
Summary: Exporting framework always export the default framework
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
: 17410 (view as bug list)
Depends on: 16035
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-03 14:14 UTC by Jonathan Druart
Modified: 2019-06-27 09:24 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17389: (bug 16035 follow-up) Fix export non-default frameworks (1.12 KB, patch)
2016-10-03 14:17 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 17389: Clear logs (1.36 KB, patch)
2016-10-03 14:25 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 17389: (bug 16035 follow-up) Fix export non-default frameworks (1.21 KB, patch)
2016-10-03 17:01 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 17389: Clear logs (1.45 KB, patch)
2016-10-03 17:02 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
[PASSED QA] Bug 17389: (bug 16035 follow-up) Fix export non-default frameworks (1.26 KB, patch)
2016-10-11 09:45 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 17389: Clear logs (1.51 KB, patch)
2016-10-11 09:46 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-10-03 14:14:09 UTC

    
Comment 1 Jonathan Druart 2016-10-03 14:14:26 UTC
From:
  commit 705097f938ba9334c21b3e6f006bd7c9ba38763c
    Bug 16035: MARC default bibliographic framework Export fix
Comment 2 Jonathan Druart 2016-10-03 14:17:35 UTC
Created attachment 55975 [details] [review]
Bug 17389: (bug 16035 follow-up) Fix export non-default frameworks

Trivial patch, no need to explain anything :)

Test plan:
Export default framework
Export other frameworks
=> The frameworkcode column should contain the framework code
Comment 3 Jonathan Druart 2016-10-03 14:25:30 UTC
Created attachment 55977 [details] [review]
Bug 17389: Clear logs

Logs are full of:
Use of uninitialized value in substitution (s///) at
C4/ImportExportFramework.pm line 282.
Use of uninitialized value in concatenation (.) or string at
C4/ImportExportFramework.pm line 283.

Some field are NULL in DB, we need to init the value to an empty string
to avoid these warnings.

Note: This fix is not related to the original bug
Comment 4 Héctor Eduardo Castro Avalos 2016-10-03 17:01:55 UTC
Created attachment 55983 [details] [review]
[SIGNED-OFF]Bug 17389: (bug 16035 follow-up) Fix export non-default frameworks

Trivial patch, no need to explain anything :)

Test plan:
Export default framework
Export other frameworks
=> The frameworkcode column should contain the framework code

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Works as advertised
Comment 5 Héctor Eduardo Castro Avalos 2016-10-03 17:02:06 UTC
Created attachment 55984 [details] [review]
[SIGNED-OFF]Bug 17389: Clear logs

Logs are full of:
Use of uninitialized value in substitution (s///) at
C4/ImportExportFramework.pm line 282.
Use of uninitialized value in concatenation (.) or string at
C4/ImportExportFramework.pm line 283.

Some field are NULL in DB, we need to init the value to an empty string
to avoid these warnings.

Note: This fix is not related to the original bug
Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Warnings avoided
Comment 6 Katrin Fischer 2016-10-11 09:45:46 UTC
Created attachment 56153 [details] [review]
[PASSED QA] Bug 17389: (bug 16035 follow-up) Fix export non-default frameworks

Trivial patch, no need to explain anything :)

Test plan:
Export default framework
Export other frameworks
=> The frameworkcode column should contain the framework code

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Works as advertised

Signed-off-by: Katrin Fischer  <katrin.fischer@bsz-bw.de>
Comment 7 Katrin Fischer 2016-10-11 09:46:02 UTC
Created attachment 56154 [details] [review]
[PASSED QA] Bug 17389: Clear logs

Logs are full of:
Use of uninitialized value in substitution (s///) at
C4/ImportExportFramework.pm line 282.
Use of uninitialized value in concatenation (.) or string at
C4/ImportExportFramework.pm line 283.

Some field are NULL in DB, we need to init the value to an empty string
to avoid these warnings.

Note: This fix is not related to the original bug
Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Warnings avoided

Signed-off-by: Katrin Fischer  <katrin.fischer@bsz-bw.de>
Comment 8 Brendan Gallagher 2016-10-14 09:34:45 UTC
Pushed to Master - Should be in the November 16.11 Release.  Thanks!
Comment 9 Frédéric Demians 2016-10-22 12:29:14 UTC
Pushed in 16.05. Will be in 16.05.05.
Comment 10 Julian Maurice 2016-10-24 10:02:42 UTC
Pushed to 3.22.x, will be in 3.22.12
Comment 11 Mark Tompsett 2017-02-19 00:14:38 UTC
*** Bug 17410 has been marked as a duplicate of this bug. ***