Bug 17407 - Fields cataloged using MARC21 880 are only searchable using keyword search
Summary: Fields cataloged using MARC21 880 are only searchable using keyword search
Status: RESOLVED DUPLICATE of bug 15187
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-05 19:37 UTC by Barton Chittenden
Modified: 2019-06-10 08:38 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Example data, marcxml (10.35 KB, application/xml)
2016-10-05 19:41 UTC, Barton Chittenden
Details
Example data, marc / utf8 (2.51 KB, text/plain)
2016-10-05 19:42 UTC, Barton Chittenden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Barton Chittenden 2016-10-05 19:37:20 UTC
According to http://www.loc.gov/marc/bibliographic/bd880.html, the MARC21 880 field is used to store versions of other MARC21 fields that have a different representation than the main cataloged fields. This would be used, for instance, to hold title or author information not stored in a Latin character set.

The 880 field is then linked back to 245 (Title), 100 (author), etc, via 880$6.

The $6 subfield follows the linkage rules here: http://www.loc.gov/marc/bibliographic/ecbdcntf.html under '$6 - Linkage'.

... the linkage fields are used to give context -- which field / occurrence is being linked to, which language / is being used, and whether the script is written right-to-left or left-to-right.

--

Without this development, titles cataloged using 880 fields can be searched using keyword searches, but searches using the linked title, author, subject are not searchable using title, author, subject searches.

This will be an issue for both Zebra and Elastic search.
Comment 1 Barton Chittenden 2016-10-05 19:41:10 UTC
Created attachment 56059 [details]
Example data, marcxml
Comment 2 Barton Chittenden 2016-10-05 19:42:05 UTC
Created attachment 56060 [details]
Example data, marc / utf8
Comment 3 Katrin Fischer 2016-10-16 13:43:08 UTC
I'd really like to see this. Records from our union catalog contain the original script in 880.
Comment 4 Katrin Fischer 2019-06-10 08:38:34 UTC

*** This bug has been marked as a duplicate of bug 15187 ***