Bug 17540 - auth_values_input_www.t is broken
Summary: auth_values_input_www.t is broken
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 17216
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-02 11:53 UTC by Jonathan Druart
Modified: 2017-06-14 22:16 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17540: (Bug 7216 followup) Fix tests for auth_values_input_www.t (4.61 KB, patch)
2016-11-02 11:55 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 17540: (Bug 7216 followup) Fix tests for auth_values_input_www.t (4.67 KB, patch)
2016-11-02 15:00 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 17540: (Bug 7216 followup) Fix tests for auth_values_input_www.t (4.71 KB, patch)
2016-11-03 15:08 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-11-02 11:53:29 UTC
% prove t/db_dependent/www/auth_values_input_www.t
t/db_dependent/www/auth_values_input_www.t .. 1/28 
#   Failed test at t/db_dependent/www/auth_values_input_www.t line 96.
#          got: '0'
#     expected: '1'

#   Failed test at t/db_dependent/www/auth_values_input_www.t line 97.
#          got: '0'
#     expected: '1'

#   Failed test 'UTF-8 (Greek) chars are correctly present. Good'
#   at t/db_dependent/www/auth_values_input_www.t line 105.
Use of uninitialized value in string ne at t/db_dependent/www/auth_values_input_www.t line 118.

#   Failed test 'error, link to delete not working'
#   at t/db_dependent/www/auth_values_input_www.t line 118.
t/db_dependent/www/auth_values_input_www.t .. 16/28 
#   Failed test at t/db_dependent/www/auth_values_input_www.t line 150.
#          got: '0'
#     expected: '1'

#   Failed test 'UTF-8 not Latin-1 second test is OK. Good'
#   at t/db_dependent/www/auth_values_input_www.t line 158.
Use of uninitialized value in string ne at t/db_dependent/www/auth_values_input_www.t line 171.

#   Failed test 'error, link to delete not working'
#   at t/db_dependent/www/auth_values_input_www.t line 171.
# Looks like you failed 7 tests of 28.
t/db_dependent/www/auth_values_input_www.t .. Dubious, test returned 7 (wstat 1792, 0x700)
Failed 7/28 subtests 

Test Summary Report
-------------------
t/db_dependent/www/auth_values_input_www.t (Wstat: 1792 Tests: 28 Failed: 7)
  Failed tests:  8-9, 14-15, 22, 27-28
  Non-zero exit status: 7
Files=1, Tests=28,  3 wallclock secs ( 0.01 usr  0.01 sys +  0.71 cusr  0.54 csys =  1.27 CPU)
Comment 1 Jonathan Druart 2016-11-02 11:53:58 UTC
This is caused by bug 17216 which modified the structure of the AV admin page
Comment 2 Jonathan Druart 2016-11-02 11:55:38 UTC
Created attachment 57078 [details] [review]
Bug 17540: (Bug 7216 followup) Fix tests for auth_values_input_www.t

This is caused by bug 17216 which modified the structure of the AV admin
page

Test plan:
  prove t/db_dependent/www/auth_values_input_www.t
should return green
Comment 3 Claire Gravely 2016-11-02 14:42:42 UTC
test failed for me:

t/db_dependent/www/auth_values_input_www.t .. You tried to plan twice at t/db_dependent/www/auth_values_input_www.t line 47.
# Looks like your test exited with 255 before it could output anything.
t/db_dependent/www/auth_values_input_www.t .. Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 33/33 subtests
Comment 4 Josef Moravec 2016-11-02 15:00:28 UTC
Created attachment 57105 [details] [review]
[SIGNED-OFF] Bug 17540: (Bug 7216 followup) Fix tests for auth_values_input_www.t

This is caused by bug 17216 which modified the structure of the AV admin
page

Test plan:
  prove t/db_dependent/www/auth_values_input_www.t
should return green

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 5 Josef Moravec 2016-11-02 15:00:59 UTC
Test passed cleanly for me...
Comment 6 Jonathan Druart 2016-11-02 15:04:17 UTC
(In reply to Claire Gravely from comment #3)
> test failed for me:
> 
> t/db_dependent/www/auth_values_input_www.t .. You tried to plan twice at
> t/db_dependent/www/auth_values_input_www.t line 47.
> # Looks like your test exited with 255 before it could output anything.
> t/db_dependent/www/auth_values_input_www.t .. Dubious, test returned 255
> (wstat 65280, 0xff00)
> Failed 33/33 subtests

This is because you did not export KOHA_INTRANET_URL and KOHA_OPAC_URL
Comment 7 Claire Gravely 2016-11-02 16:55:12 UTC
(In reply to Jonathan Druart from comment #6)
> (In reply to Claire Gravely from comment #3)
> > test failed for me:
> > 
> > t/db_dependent/www/auth_values_input_www.t .. You tried to plan twice at
> > t/db_dependent/www/auth_values_input_www.t line 47.
> > # Looks like your test exited with 255 before it could output anything.
> > t/db_dependent/www/auth_values_input_www.t .. Dubious, test returned 255
> > (wstat 65280, 0xff00)
> > Failed 33/33 subtests
> 
> This is because you did not export KOHA_INTRANET_URL and KOHA_OPAC_URL

Thanks, yes, worked on kohadevbox!
Comment 8 Tomás Cohen Arazi 2016-11-03 15:08:51 UTC
Created attachment 57138 [details] [review]
Bug 17540: (Bug 7216 followup) Fix tests for auth_values_input_www.t

This is caused by bug 17216 which modified the structure of the AV admin
page

Test plan:
  prove t/db_dependent/www/auth_values_input_www.t
should return green

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 9 Kyle M Hall 2016-11-04 11:08:48 UTC
Pushed to master for 16.11, thanks Jonathan!
Comment 10 Mason James 2016-11-30 08:25:28 UTC
blocked by DB changes, passing for 16.05