Bug 17563 - Acquisition/CancelReceipt.t is broken
Summary: Acquisition/CancelReceipt.t is broken
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 13321
Blocks: 13726
  Show dependency treegraph
 
Reported: 2016-11-07 10:54 UTC by Jonathan Druart
Modified: 2017-06-14 22:15 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 17563: Fix Acquisition/CancelReceipt.t (1.21 KB, patch)
2016-11-07 10:57 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 17563: Fix Acquisition/CancelReceipt.t (1.28 KB, patch)
2016-11-07 11:32 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 17563: Fix Acquisition/CancelReceipt.t (1.32 KB, patch)
2016-11-08 19:13 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 17563: (followup) Silence undef warnings (1.15 KB, patch)
2016-11-08 19:13 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2016-11-07 10:54:03 UTC

    
Comment 1 Jonathan Druart 2016-11-07 10:54:57 UTC
Caused by
  commit 20d9ed618fbe3cdcb9c04444a1f8a584b0364069
    Bug 13321: Rename variables
Comment 2 Jonathan Druart 2016-11-07 10:57:01 UTC
Created attachment 57250 [details] [review]
Bug 17563: Fix Acquisition/CancelReceipt.t

Test plan:
  prove t/db_dependent/Acquisition/CancelReceipt.t
should return green

Confirm that the changes made by
  commit 20d9ed618fbe3cdcb9c04444a1f8a584b0364069
    Bug 13321: Rename variables
was wrong for the budget_id var and that this patch reverts it
Comment 3 Josef Moravec 2016-11-07 11:32:59 UTC
Created attachment 57254 [details] [review]
[SIGNED-OFF] Bug 17563: Fix Acquisition/CancelReceipt.t

Test plan:
  prove t/db_dependent/Acquisition/CancelReceipt.t
should return green

Confirm that the changes made by
  commit 20d9ed618fbe3cdcb9c04444a1f8a584b0364069
    Bug 13321: Rename variables
was wrong for the budget_id var and that this patch reverts it

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 4 Tomás Cohen Arazi 2016-11-08 19:13:04 UTC
Created attachment 57346 [details] [review]
Bug 17563: Fix Acquisition/CancelReceipt.t

Test plan:
  prove t/db_dependent/Acquisition/CancelReceipt.t
should return green

Confirm that the changes made by
  commit 20d9ed618fbe3cdcb9c04444a1f8a584b0364069
    Bug 13321: Rename variables
was wrong for the budget_id var and that this patch reverts it

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 5 Tomás Cohen Arazi 2016-11-08 19:13:11 UTC
Created attachment 57347 [details] [review]
Bug 17563: (followup) Silence undef warnings

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 6 Kyle M Hall 2016-11-10 13:37:25 UTC
Pushed to master for 16.11, thanks Jonathan, Tomas!
Comment 7 Mason James 2016-11-30 11:02:21 UTC
blocked by enhancement, passing for 16.05