Bug 17739 - Opac explodes when clicking on user tag when using elastic
Summary: Opac explodes when clicking on user tag when using elastic
Status: RESOLVED DUPLICATE of bug 18822
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching - Elasticsearch (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on: 12478
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-07 14:56 UTC by Josef Moravec
Modified: 2018-05-25 09:40 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Moravec 2016-12-07 14:56:02 UTC
The log says:
Can't locate object method "subfield" via package "<?xml version="1.0" encoding="UTF-8"?><record .. whole xml record" at C4/Search.pm line 1925

To reproduce
1) Set syspref SearchEngine to Elastic
2) go to opac detail and add a tag
3) try to click the added tag
Comment 1 Nick Clemens 2018-05-25 09:40:29 UTC
This is the same issue as in 18822 - we assume we got MARC::Record objects from zebra, but in this case we have raw xml fetched from the DB directly.

Possibly in the future we should index the tags and search them using the search engine instead of a direct db call

*** This bug has been marked as a duplicate of bug 18822 ***