Bug 17832 - arl (accelerated reading level) and ard (? -- Title point value) searches do not return results
Summary: arl (accelerated reading level) and ard (? -- Title point value) searches do ...
Status: RESOLVED DUPLICATE of bug 20078
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-30 20:57 UTC by Barton Chittenden
Modified: 2019-03-12 23:01 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Barton Chittenden 2016-12-30 20:57:19 UTC
Prepending "arl:" or "ard:" to search terms should use the "ard" or "arl" indexes.

arl should index 526$c, and ard should index 526$d.

Here are some values for 526$c, taken from the koha database backing http://catalog.bywatersolutions.com/.

select biblionumber, title,  ExtractValue( marcxml, '//datafield[@tag=526]/subfield[@code="c"]' ) as 'arl' from biblioitems inner join biblio using (biblionumber) where ExtractValue( marcxml, '//datafield[@tag=526]/subfield[@code="c"]' ) != '' limit 10;                                                                                              
+--------------+-----------------------------------------------+-----------------+
| biblionumber | title                                         | arl             |
+--------------+-----------------------------------------------+-----------------+
|        33556 | Boy, were we wrong about dinosaurs! /         | 5.0             |
|        37781 | Who really discovered America? :              | 100             |
|        39460 | Mummies in the morning /                      | 2.7 grade level |
|        45646 | Endymion Spring /                             | 6.3             |
|        47364 | The year we disappeared :                     | 5.7             |
|        48039 | There was an old lady who swallowed Fly Guy / | 1.6             |
|        48041 | Ants /                                        | 1.5 1.0         |
|        48042 | The Arabian horse /                           | 3.5 4.9         |
|        48043 | Athena /                                      | 4.4 4.4         |
|        48044 | Aunts /                                       | 1.3 0.9         |
+--------------+-----------------------------------------------+-----------------+
10 rows in set (5.19 sec)

... so a search of "arl: 2.7 grade level" *should* return results for at least "Mummies in the morning /"

Instead http://catalog.bywatersolutions.com/cgi-bin/koha/opac-search.pl?idx=&q=arl%3A+2.7+grade+level&branch_group_limit=

returns no results.

Likewise for ard

select biblionumber, title,  ExtractValue( marcxml, '//datafield[@tag=526]/subfield[@code="d"]' ) as 'ard' from biblioitems inner join biblio using (biblionumber) where ExtractValue( marcxml, '//datafield[@tag=526]/subfield[@code="d"]' ) != '' limit 10
+--------------+-----------------------------------------------+----------+
| biblionumber | title                                         | ard      |
+--------------+-----------------------------------------------+----------+
|        33556 | Boy, were we wrong about dinosaurs! /         | 0.5      |
|        37781 | Who really discovered America? :              | 2000     |
|        39460 | Mummies in the morning /                      | 1.0 pts. |
|        45646 | Endymion Spring /                             | 13.      |
|        47364 | The year we disappeared :                     | 13       |
|        48039 | There was an old lady who swallowed Fly Guy / | 0.5      |
|        48041 | Ants /                                        | 1 0.5    |
|        48042 | The Arabian horse /                           | 3 0.5    |
|        48043 | Athena /                                      | 3 0.5    |
|        48044 | Aunts /                                       | 1 0.5    |
+--------------+-----------------------------------------------+----------+

A search for "ard: 1.0 pts" should return "Mummies in the morning /"

But http://catalog.bywatersolutions.com/cgi-bin/koha/opac-search.pl?idx=&q=ard%3A+1.0+pts&branch_group_limit=

Does not.
Comment 1 Katrin Fischer 2019-03-12 23:01:50 UTC

*** This bug has been marked as a duplicate of bug 20078 ***