Bug 18007 - Interface updates to notices and notice previews
Summary: Interface updates to notices and notice previews
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Notices (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Josef Moravec
URL:
Whiteboard:
Keywords:
Depends on: 17981
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-27 18:37 UTC by Owen Leonard
Modified: 2018-05-22 10:02 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 18007 - Interface updates to notices and notice previews (22.65 KB, patch)
2017-01-27 19:10 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 18007: Interface updates to notices and notice previews (24.67 KB, patch)
2017-10-13 15:56 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 18007: Interface updates to notices and notice previews (24.73 KB, patch)
2017-11-28 10:14 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 18007: Interface updates to notices and notice previews (26.20 KB, patch)
2018-01-05 16:02 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 18007: Interface updates to notices and notice previews (25.96 KB, patch)
2018-03-23 16:36 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 18007: Interface updates to notices and notice previews (23.07 KB, patch)
2018-04-13 12:35 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 18007: Interface updates to notices and notice previews (23.07 KB, patch)
2018-04-13 13:49 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 18007: Interface updates to notices and notice previews (22.73 KB, patch)
2018-04-15 09:02 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 18007: Interface updates to notices and notice previews (22.76 KB, patch)
2018-04-16 13:55 UTC, Josef Moravec
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2017-01-27 18:37:39 UTC
An upcoming patch will:
    - Restructure the template for side-by-side comparisons of notice updates
    - Move JavaScript out of template into separate file
    - Improving form validation through use of validation plugin
    - Give better visual feedback for AJAX form checks
Comment 1 Owen Leonard 2017-01-27 19:10:13 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2017-02-08 10:19:29 UTC
Screenshot: https://pageshot.net/pVRqSxln4A9cqjtM/pro.kohadev.vm
Comment 3 Jonathan Druart 2017-08-08 19:02:21 UTC
Owen, could you rebase it please?

CONFLICT (content): Merge conflict in koha-tmpl/intranet-tmpl/prog/en/modules/tools/letter.tt
Comment 4 Owen Leonard 2017-10-13 15:56:02 UTC Comment hidden (obsolete)
Comment 5 Claire Gravely 2017-11-28 10:14:26 UTC Comment hidden (obsolete)
Comment 6 Jonathan Druart 2018-01-05 16:02:43 UTC Comment hidden (obsolete)
Comment 7 Julian Maurice 2018-03-12 11:32:05 UTC
Patch does not apply anymore.
Can you rebase it please ?
Comment 8 Katrin Fischer 2018-03-12 12:44:11 UTC
Hi Julian, did you notice the dependency?
Comment 9 Jonathan Druart 2018-03-23 16:36:26 UTC Comment hidden (obsolete)
Comment 10 Josef Moravec 2018-04-11 19:37:19 UTC
Need rebase on top af changes on bug 17981
Comment 11 Owen Leonard 2018-04-13 12:35:29 UTC
Created attachment 74163 [details] [review]
Bug 18007: Interface updates to notices and notice previews

This patch makes changes to the form for adding and editing notices, and
to the template for viewing a rendered preview of notices.

- Preview now shows side-by-side comparisons
- JavaScript has been movied out of template into separate file
- Validation of the add/edit form improved through use of validation
  plugin
- There is now better visual feedback for AJAX form checks

To test, apply the patch on top of those for Bug 17981

- Add a new notice.
  - Confirm that the form can't be submitted without data in the "code"
    and "name" fields.
  - Confirm that the form can't be submitted without filling in at least
    one message template (subject and body).
  - Confirm that you cannot submit the form while using an
    existing notice code.
  - Follow Bug 17981's test plan for testing the preview function.
    Confirm that the preview loads correctly and looks correct.

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>
Comment 12 Owen Leonard 2018-04-13 13:49:08 UTC
Created attachment 74168 [details] [review]
Bug 18007: Interface updates to notices and notice previews

This patch makes changes to the form for adding and editing notices, and
to the template for viewing a rendered preview of notices.

- Preview now shows side-by-side comparisons
- JavaScript has been movied out of template into separate file
- Validation of the add/edit form improved through use of validation
  plugin

To test, apply the patch on top of those for Bug 17981

- Add a new notice.
  - Confirm that the form can't be submitted without data in the "code"
    and "name" fields.
  - Confirm that the form can't be submitted without filling in at least
    one message template (subject and body).
  - Confirm that you cannot submit the form while using an
    existing notice code.
  - Follow Bug 17981's test plan for testing the preview function.
    Confirm that the preview loads correctly and looks correct.
    - Test both with old syntax messages which require conversion and
      messages in template-toolkit syntax.
Comment 13 Katrin Fischer 2018-04-15 09:02:31 UTC
Created attachment 74191 [details] [review]
Bug 18007: Interface updates to notices and notice previews

This patch makes changes to the form for adding and editing notices, and
to the template for viewing a rendered preview of notices.

- Preview now shows side-by-side comparisons
- JavaScript has been movied out of template into separate file
- Validation of the add/edit form improved through use of validation
  plugin

To test, apply the patch on top of those for Bug 17981

- Add a new notice.
  - Confirm that the form can't be submitted without data in the "code"
    and "name" fields.
  - Confirm that the form can't be submitted without filling in at least
    one message template (subject and body).
  - Confirm that you cannot submit the form while using an
    existing notice code.
  - Follow Bug 17981's test plan for testing the preview function.
    Confirm that the preview loads correctly and looks correct.
    - Test both with old syntax messages which require conversion and
      messages in template-toolkit syntax.

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Fixed conflicts caused by bug 20538.
Comment 14 Josef Moravec 2018-04-16 13:55:00 UTC
Created attachment 74237 [details] [review]
Bug 18007: Interface updates to notices and notice previews

This patch makes changes to the form for adding and editing notices, and
to the template for viewing a rendered preview of notices.

- Preview now shows side-by-side comparisons
- JavaScript has been movied out of template into separate file
- Validation of the add/edit form improved through use of validation
  plugin

To test, apply the patch on top of those for Bug 17981

- Add a new notice.
  - Confirm that the form can't be submitted without data in the "code"
    and "name" fields.
  - Confirm that the form can't be submitted without filling in at least
    one message template (subject and body).
  - Confirm that you cannot submit the form while using an
    existing notice code.
  - Follow Bug 17981's test plan for testing the preview function.
    Confirm that the preview loads correctly and looks correct.
    - Test both with old syntax messages which require conversion and
      messages in template-toolkit syntax.

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Fixed conflicts caused by bug 20538.

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 15 Jonathan Druart 2018-04-16 17:12:45 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 16 Nick Clemens 2018-05-22 10:02:40 UTC
Enhancement, not backported for  17.11