Bug 18048 - Add index on biblioitems.ean
Summary: Add index on biblioitems.ean
Status: RESOLVED DUPLICATE of bug 13766
Alias: None
Product: Koha
Classification: Unclassified
Component: Database (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-03 13:31 UTC by Katrin Fischer
Modified: 2017-08-17 12:04 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2017-02-03 13:31:20 UTC
In big databases querying on the EAN can take a while, it would be nice to have an index on this column as we have on other columns with standard numbers in this table already:

 196   PRIMARY KEY  (`biblioitemnumber`),
 197   KEY `bibinoidx` (`biblioitemnumber`),
 198   KEY `bibnoidx` (`biblionumber`),
 199   KEY `itemtype_idx` (`itemtype`),
 200   KEY `isbn` (`isbn`(255)),
 201   KEY `issn` (`issn`(255)),
 202   KEY `publishercode` (`publishercode`),
Comment 1 Katrin Fischer 2017-08-17 12:04:55 UTC

*** This bug has been marked as a duplicate of bug 13766 ***