Bug 18075 - Confirming a hold after a transfer does not make it waiting
Summary: Confirming a hold after a transfer does not make it waiting
Status: RESOLVED DUPLICATE of bug 17940
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Target Milestone: ---
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-07 16:58 UTC by Christopher Brannon
Modified: 2017-02-08 16:50 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Brannon 2017-02-07 16:58:35 UTC
When an item from Library A is reserved and set to be picked up at Library B, the hold buttons fail to confirm or cancel during check in at Library B when the item is transferred from Library A.

To Test:
* Create a hold for item at Library A to be picked up at Library B.
* Check in item at Library A to trigger the transfer.
* Switch to Library B and check in item.
* Confirm the hold.
* Go to item record and look at holds.  Notice the item is not waiting and still shows in transit.
* Check in item at Library B again.
* Cancel the hold.
* Go to item record and look at holds.  Notice the item is still active and in transit.

If do everything the same except trigger the transfer at Library A, when checked in at Library B and confirmed, it DOES work.

Something in the transfer appears to break the hold confirmation/cancel at the destination.

Christopher
Comment 1 Owen Leonard 2017-02-07 17:00:32 UTC
I was able to reproduce this problem in master.
Comment 2 Jonathan Druart 2017-02-08 16:50:13 UTC
This sounds like a duplicate of bug 17940. Please reopen if I am wrong.

*** This bug has been marked as a duplicate of bug 17940 ***