Bug 18301 - export_records.pl from the tools menu fails with the message Internal Server Error
Summary: export_records.pl from the tools menu fails with the message Internal Server ...
Status: RESOLVED DUPLICATE of bug 18312
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: 16.11
Hardware: All Linux
: P5 - low normal (vote)
Assignee: Marc Véron
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-19 16:41 UTC by Steven F. Schmieder
Modified: 2017-03-29 14:35 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 18301: export_records.pl from the tools menu fails with the message Internal Server (1.55 KB, patch)
2017-03-20 15:00 UTC, Marc Véron
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Steven F. Schmieder 2017-03-19 16:41:06 UTC
After applying the latest update 16.11.05.000 on three servers, one running Debian 8.7 (Jessie), the second with Debian 9 RC2 (Stretch), and the third with Ubuntu 14.04, trying to export bibliographic records from the tools menu fails with an Internal Server Error on the Debian hosts. The Ubuntu hosts returns:

Software error:

Can't use an undefined value as a HASH reference at /usr/share/koha/intranet/cgi-bin/tools/export.pl line 75

For help, please send mail, etc.


Steven F. Schmieder
Comment 1 Marc Véron 2017-03-20 10:35:18 UTC
Confirmed on current master.

To reproduce:
- Go to Home > Tools > Export data
- Choose tab 'Export bibliographic records' or 'Export authority records'
- Click 'Export (...)'

Result for both:
'Internal server error' 

Plack error log says:

Can't use an undefined value as a HASH reference at /usr/share/koha/intranet/cgi-bin/tools/export.pl line 75
Comment 2 Marc Véron 2017-03-20 15:00:49 UTC
Created attachment 61323 [details] [review]
Bug 18301: export_records.pl from the tools menu fails with the message Internal Server

To reproduce:
- Go to Home > Tools > Export data
- Choose tab 'Export bibliographic records' or 'Export authority records'
- Click 'Export (...)'

Result for both:
'Internal server error'

To test:
- Apply patch
- Try to reproduce error
- Test export with and without 'Use a file'
Comment 3 Jonathan Druart 2017-03-29 14:35:47 UTC

*** This bug has been marked as a duplicate of bug 18312 ***