Bug 18466 - No article requests breaks the opac-user-views block
Summary: No article requests breaks the opac-user-views block
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Target Milestone: ---
Assignee: Eric Phetteplace
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 14610
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-21 00:12 UTC by Eric Phetteplace
Modified: 2018-12-03 20:03 UTC (History)
7 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
screenshot (25.80 KB, image/png)
2017-04-21 00:12 UTC, Eric Phetteplace
Details
Bug 18466: article requests box outline in opac (14.02 KB, patch)
2017-04-21 00:26 UTC, Eric Phetteplace
Details | Diff | Splinter Review
Bug 18466: article requests box outline in opac (14.14 KB, patch)
2017-04-21 21:16 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 18466: article requests box outline in opac (14.22 KB, patch)
2017-04-24 16:35 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Phetteplace 2017-04-21 00:12:56 UTC
Created attachment 62508 [details]
screenshot

If you have no open article requests, the tabbed box with checked out items, article requests. etc. just below the patron's name is awkward looking when you click on the article requests tab: the box below the tabs disappears because the way the `[% IF Koha.Preference('ArticleRequests') && IF borrower.article_requests_current.count %]` condition is written no table is printed at all.

Sorry if I'm articulating this poorly, a screenshot is attached.

Patch coming shortly, I'm just going to mimic the behavior of the checked out items section when there are no checked out items.
Comment 1 Eric Phetteplace 2017-04-21 00:26:00 UTC
Created attachment 62509 [details] [review]
Bug 18466: article requests box outline in opac
Comment 2 Marc Véron 2017-04-21 21:14:57 UTC
Could reproduce issue, with patch page looks much nicer.
QA tools complain because of line 818, but only change in this line is indentation. 

Signing off.
Comment 3 Marc Véron 2017-04-21 21:16:05 UTC
Created attachment 62563 [details] [review]
Bug 18466: article requests box outline in opac

To test:
1) apply patch
2) ensure ArticleRequests is set to Enable
3) sign in as a user with no article requests on the OPAC side
4) click the 'article requests' tab & see the box & message

Sponsored-By: California College of the Arts

Signed-off-by: Marc Véron <veron@veron.ch>
Comment 4 Eric Phetteplace 2017-04-21 22:21:17 UTC
Thanks, Marc!
Comment 5 Jonathan Druart 2017-04-24 16:35:03 UTC
Created attachment 62616 [details] [review]
Bug 18466: article requests box outline in opac

To test:
1) apply patch
2) ensure ArticleRequests is set to Enable
3) sign in as a user with no article requests on the OPAC side
4) click the 'article requests' tab & see the box & message

Sponsored-By: California College of the Arts

Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 6 Kyle M Hall 2017-04-24 17:25:28 UTC
Pushed to master for 17.05, thanks Eric!
Comment 7 Katrin Fischer 2017-05-13 11:50:25 UTC
This patch has been pushed to 16.11.x and will be in 16.11.08.
Comment 8 Mason James 2017-05-23 23:28:44 UTC
Blocked by Enhancement (bz14610), skipping for 16.05.x