Bug 18474 - Placing multiple holds from results breaks when patron is searched for
Summary: Placing multiple holds from results breaks when patron is searched for
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 20392 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-21 14:22 UTC by Nick Clemens
Modified: 2018-10-24 09:13 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 18474: Restore multiple holds when patron is searched for (5.21 KB, patch)
2017-12-21 19:02 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 18474: Restore multiple holds when patron is searched for (5.44 KB, patch)
2018-03-15 11:28 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 18474: Restore multiple holds when patron is searched for (5.49 KB, patch)
2018-03-26 07:44 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Bug 18474: Restore multiple holds when patron is searched for (5.58 KB, patch)
2018-03-30 11:08 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 18474 [QA Followup]: Remove useless else in template (1.18 KB, patch)
2018-03-30 11:09 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2017-04-21 14:22:40 UTC
To recreate:

1 - Search in staff client
2 - Check multiple titles
3 - Click 'Place hold' button in toolbar
4 - Type 'a' into Patron: search (or any search the returns multiple patrons)
5 - Select a patron from the results
6 - You are taken to screen to place a single hold
7 - Repeat 1-3
8 - Enter a cardnumber or type and select a patron directly
9 - You can place the multiple holds as expected.
Comment 1 NancyK. 2017-12-20 22:57:39 UTC
I just had a staff member report this after our upgrade from 16.11 to 17.05
Looks like 17.05 broke a formerly good feature.
Anyone interested in fixing it back?  Please.

NancyK
Comment 2 Jonathan Druart 2017-12-21 19:02:21 UTC
Created attachment 70079 [details] [review]
Bug 18474: Restore multiple holds when patron is searched for

We lost the ability to place multiple holds when we are searching for
patrons. The multi_holds parameter is lost and not handled correctly in
the template.

Test plan:
- Make sure you can place multiple holds for a patron you will search for
- Same for simple hold

TODO the multiple holds view should not be displayed if only 1 record
has been selected from the search result.
Comment 3 Jonathan Druart 2017-12-21 19:03:16 UTC
I'd say that it is broken in all our supported branches.
Comment 4 Claude 2018-03-14 08:29:20 UTC
I had system error while testing on a sandbox, with the following message :

Global symbol "$multihold" requires explicit package name (did you forget to declare "my $multihold"?) at /home/koha/src/reserve/request.pl line 129.
Execution of /home/koha/src/reserve/request.pl aborted due to compilation errors.

best regards
Comment 5 Nick Clemens 2018-03-15 11:28:12 UTC
Created attachment 72934 [details] [review]
Bug 18474: Restore multiple holds when patron is searched for

We lost the ability to place multiple holds when we are searching for
patrons. The multi_holds parameter is lost and not handled correctly in
the template.

Test plan:
- Make sure you can place multiple holds for a patron you will search for
- Same for simple hold

TODO the multiple holds view should not be displayed if only 1 record
has been selected from the search result.
Comment 6 sandboxes@biblibre.com 2018-03-26 07:44:12 UTC
Patch tested with a sandbox, by claude brayer <claude.brayer@cea.fr>
Comment 7 sandboxes@biblibre.com 2018-03-26 07:44:38 UTC
Created attachment 73279 [details] [review]
Bug 18474: Restore multiple holds when patron is searched for

We lost the ability to place multiple holds when we are searching for
patrons. The multi_holds parameter is lost and not handled correctly in
the template.

Test plan:
- Make sure you can place multiple holds for a patron you will search for
- Same for simple hold

TODO the multiple holds view should not be displayed if only 1 record
has been selected from the search result.

Signed-off-by: claude brayer <claude.brayer@cea.fr>
Comment 8 Kyle M Hall 2018-03-30 11:08:54 UTC
Created attachment 73464 [details] [review]
Bug 18474: Restore multiple holds when patron is searched for

We lost the ability to place multiple holds when we are searching for
patrons. The multi_holds parameter is lost and not handled correctly in
the template.

Test plan:
- Make sure you can place multiple holds for a patron you will search for
- Same for simple hold

TODO the multiple holds view should not be displayed if only 1 record
has been selected from the search result.

Signed-off-by: claude brayer <claude.brayer@cea.fr>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 9 Kyle M Hall 2018-03-30 11:09:02 UTC
Created attachment 73465 [details] [review]
Bug 18474 [QA Followup]: Remove useless else in template

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 10 Kyle M Hall 2018-03-30 11:16:52 UTC
Bug 18474 and Bug 20392 appear to solve the same problem. Leaving to RM to decide which to use!
Comment 11 Jonathan Druart 2018-04-02 19:25:48 UTC
*** Bug 20392 has been marked as a duplicate of this bug. ***
Comment 12 Jonathan Druart 2018-04-02 21:14:35 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 13 Nick Clemens 2018-05-14 21:23:40 UTC
Pushed to stable for 17.11.06

Awesome work all!
Comment 14 Fridolin SOMERS 2018-05-22 09:48:56 UTC
Pushed to 17.05.x for v17.05.12