Bug 18509 - Minor performance improvement for overdue_notices.pl
Summary: Minor performance improvement for overdue_notices.pl
Status: RESOLVED DUPLICATE of bug 17952
Alias: None
Product: Koha
Classification: Unclassified
Component: Command-line Utilities (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-28 14:56 UTC by Martin Renvoize
Modified: 2017-05-01 18:31 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Renvoize 2017-04-28 14:56:18 UTC
Don't re-instantiate Koha::Calendar objects unnecessarily

We were calling Koha::Calender->new on the same branchcode within a set
of nested loops.  This is just silly, only one object is required.
Comment 1 Barton Chittenden 2017-05-01 16:39:58 UTC
This is fixed in bug 17952
Comment 2 Martin Renvoize 2017-05-01 18:31:25 UTC
Oh, nice spot, thanks for pointing that out.. means I won't have to extract it from our local branch :)

Will mark resolved duplicate and take a look at the other bug.

*** This bug has been marked as a duplicate of bug 17952 ***