Bug 18510 - Errors on Patron Details page ( moremember.pl )
Summary: Errors on Patron Details page ( moremember.pl )
Status: RESOLVED DUPLICATE of bug 18179
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low blocker (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
Depends on: 18179
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-28 15:11 UTC by Kyle M Hall
Modified: 2017-04-28 20:27 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 18510 - Errors on Patron Details page ( moremember.pl ) (1.74 KB, patch)
2017-04-28 15:13 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2017-04-28 15:11:03 UTC
Cannot use "->find" in list context at /home/vagrant/kohaclone/members/moremember.pl line 334.
Comment 1 Kyle M Hall 2017-04-28 15:13:40 UTC
Created attachment 62829 [details] [review]
Bug 18510 - Errors on Patron Details page ( moremember.pl )

Cannot use "->find" in list context at /home/vagrant/kohaclone/members/moremember.pl line 334.

Test Plan:
1) Got to moremember.pl, note error
2) Apply this patch
3) Refresh page, no error!
Comment 2 Kyle M Hall 2017-04-28 15:15:17 UTC
Question: do we need to switch all pages using patron-title.inc to passing a Koha::Patron as 'borrower'? It seems like that should be necessary, at least on some pages. Not sure which.
Comment 3 Mark Tompsett 2017-04-28 16:31:15 UTC
This was triggered by patron clubs (bug 12461), as far as I can tell, combined with bug 18179.
Comment 4 Jonathan Druart 2017-04-28 20:21:15 UTC
(In reply to Kyle M Hall from comment #2)
> Question: do we need to switch all pages using patron-title.inc to passing a
> Koha::Patron as 'borrower'? It seems like that should be necessary, at least
> on some pages. Not sure which.

Part of this is done already on bug 18403.
Comment 5 Jonathan Druart 2017-04-28 20:27:17 UTC
Patch moved to bug 18179.

*** This bug has been marked as a duplicate of bug 18179 ***