Bug 18543 - Emails for new patron accounts with the AutoEmailOpacUser preference require to enter password manually
Summary: Emails for new patron accounts with the AutoEmailOpacUser preference require ...
Status: RESOLVED DUPLICATE of bug 27812
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on: 27812
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-04 19:58 UTC by Karen
Modified: 2022-03-01 16:11 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karen 2017-05-04 19:58:02 UTC
When the AutoEmailOpacUser preference is set to Send, Koha should send an email with account details to newly created patrons. After some testing, we discovered that Koha will only send emails to patrons if the username and password are entered into the system by hand. The email is not sent when the username and password are automatically generated by the system. 

The expected behavior is that Koha would send the account details email to newly created patrons when the system automatically generates the username and the password.
Comment 1 Katrin Fischer 2017-05-10 22:57:32 UTC
Hi Karen, I think Koha can't generate the password automatically yet, so that might be a different enhancement. But you are right about the username. The current behaviour has led to a lot of questions as libraries are never sure if the email has been sent out (no way to check) and there is a lot of undocumented conditions for it to happen.
Comment 2 Fiona Borthwick 2019-12-30 16:34:50 UTC
This still happens....
Lots of libraries would like Koha to auto generate the password. The welcome email is not sent even if they use the option to click for Koha to populate with a random string. It arrives as expected if the member of staff types data into the password field.
Comment 3 Katrin Fischer 2022-02-26 21:33:10 UTC
There is Bug 27812 - Remove the ability to transmit a patron's plain text password over email now.

With a password not longer being sent, we could add the notice to the message_queue and also make other changes much more easily to make it more useful. 

The reasoning is that you should never send a password by email and we have much better options now with the password recovery feature where patrons can set their own passwords easily.
Comment 4 Martin Renvoize 2022-03-01 16:11:54 UTC
This will be resolved as part of bug 27812 so I'm marking it as a RESOLVED DUPLICATE.

Further work will take place in bug 17648 to move this notice into the message queue and then allow for further trigger area's in follow-up bugs.

*** This bug has been marked as a duplicate of bug 27812 ***