Bug 18673 - News author does not display on staff client home page
Summary: News author does not display on staff client home page
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Marc Véron
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords:
Depends on: 17855
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-25 21:03 UTC by Marc Véron
Modified: 2017-06-11 19:49 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 18673: News author does not display on staff client home page (1.23 KB, patch)
2017-05-25 21:06 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 18673: News author does not display on staff client home page (1.33 KB, patch)
2017-05-28 11:01 UTC, Alex Buckley
Details | Diff | Splinter Review
Bug 18673: News author does not display on staff client home page (1.42 KB, patch)
2017-06-02 09:23 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Véron 2017-05-25 21:03:09 UTC
News authors do not display on staff client homepage, independently of syspref 'NewsAuthorDisplay'

To verify:
- Create news with display location 'All'
- Set syspref NewsAuthorDisplay to 'Staff client only' or 'Both OPAC and staff client'
- Go to staff client
- Verify that news author does not appear (but it should)
Comment 1 Marc Véron 2017-05-25 21:06:30 UTC
Created attachment 63722 [details] [review]
Bug 18673: News author does not display on staff client home page

News authors do not display on staff client homepage, independently of
syspref 'NewsAuthorDisplay'. This patch fixes the issue.

To verify:
- Create news with display location 'All'
- Set syspref NewsAuthorDisplay to 'Staff client only' or 'Both OPAC and staff client'
- Go to staff client
- Verify that news author does not appear (but it should)

To test:
- Applly patch
- Verify that news author is displayed as expected
Comment 2 Alex Buckley 2017-05-28 11:01:59 UTC
Created attachment 63775 [details] [review]
Bug 18673: News author does not display on staff client home page

News authors do not display on staff client homepage, independently of
syspref 'NewsAuthorDisplay'. This patch fixes the issue.

To verify:
- Create news with display location 'All'
- Set syspref NewsAuthorDisplay to 'Staff client only' or 'Both OPAC and staff client'
- Go to staff client
- Verify that news author does not appear (but it should)

To test:
- Applly patch
- Verify that news author is displayed as expected

Followed test plan works as intended
Signed-off-by: Alex Buckley <alexbuckley@catalyst.net.nz>
Comment 3 Marcel de Rooy 2017-06-02 09:23:47 UTC
Created attachment 63930 [details] [review]
Bug 18673: News author does not display on staff client home page

News authors do not display on staff client homepage, independently of
syspref 'NewsAuthorDisplay'. This patch fixes the issue.

To verify:
- Create news with display location 'All'
- Set syspref NewsAuthorDisplay to 'Staff client only' or 'Both OPAC and staff client'
- Go to staff client
- Verify that news author does not appear (but it should)

To test:
- Applly patch
- Verify that news author is displayed as expected

Followed test plan works as intended
Signed-off-by: Alex Buckley <alexbuckley@catalyst.net.nz>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 4 Jonathan Druart 2017-06-05 14:46:31 UTC
Caused by bug 17855.
Comment 5 Jonathan Druart 2017-06-05 14:57:00 UTC
Pushed to master for 17.11, thanks to everybody involved!
Comment 6 Fridolin SOMERS 2017-06-09 12:48:30 UTC
Pushed to 17.05.x, will be in v17.05.01.
Comment 7 Katrin Fischer 2017-06-11 19:49:06 UTC
This fix is not needed in 16.11.x - Use Koha is already present.