Bug 18806 - Cannot revert a batch
Summary: Cannot revert a batch
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords:
: 18343 (view as bug list)
Depends on: 18242
Blocks: 18807
  Show dependency treegraph
 
Reported: 2017-06-14 18:52 UTC by Jonathan Druart
Modified: 2017-12-07 22:23 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 18806: Fix batch revert (3.27 KB, patch)
2017-06-14 18:54 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 18806: Fix batch revert (3.32 KB, patch)
2017-06-15 22:38 UTC, Lee Jamison
Details | Diff | Splinter Review
Bug 18806: Fix batch revert (3.41 KB, patch)
2017-06-16 07:54 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2017-06-14 18:52:12 UTC
Since bug 18242: When a biblio is deleted, a new transaction is created.
tools/manage-marc-import.pl use the AutoCommit flag, which does not allow nested transaction.
AutoCommit must not be used.
Comment 1 Jonathan Druart 2017-06-14 18:54:30 UTC
Created attachment 64298 [details] [review]
Bug 18806: Fix batch revert

Since bug 18242: When a biblio is deleted, a new transaction is created.
tools/manage-marc-import.pl use the AutoCommit flag, which does not
allow nested transaction.
AutoCommit must not be used.

Test plan:
Import a batch, then revert it.
The biblios must have been correctly deleted, they were not before this
patch
Comment 2 Lee Jamison 2017-06-15 22:38:01 UTC
Created attachment 64371 [details] [review]
Bug 18806: Fix batch revert

Since bug 18242: When a biblio is deleted, a new transaction is created.
tools/manage-marc-import.pl use the AutoCommit flag, which does not
allow nested transaction.
AutoCommit must not be used.

Test plan:
Import a batch, then revert it.
The biblios must have been correctly deleted, they were not before this
patch

Signed-off-by: Lee Jamison <ldjamison@marywood.edu>
Comment 3 Marcel de Rooy 2017-06-16 07:33:44 UTC
QA: Looking here now
Comment 4 Marcel de Rooy 2017-06-16 07:54:34 UTC
Created attachment 64377 [details] [review]
Bug 18806: Fix batch revert

Since bug 18242: When a biblio is deleted, a new transaction is created.
tools/manage-marc-import.pl use the AutoCommit flag, which does not
allow nested transaction.
AutoCommit must not be used.

Test plan:
Import a batch, then revert it.
The biblios must have been correctly deleted, they were not before this
patch

Signed-off-by: Lee Jamison <ldjamison@marywood.edu>
Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 5 Jonathan Druart 2017-06-19 19:38:56 UTC
Pushed to master for 17.11, thanks to everybody involved!
Comment 6 Fridolin SOMERS 2017-06-27 15:00:10 UTC
*** Bug 18343 has been marked as a duplicate of this bug. ***
Comment 7 Fridolin SOMERS 2017-06-27 15:06:37 UTC
Pushed to 17.05.x, will be in 17.05.02
Comment 8 Katrin Fischer 2017-06-27 22:05:36 UTC
This patch has been pushed to 16.11.x and will be in 16.11.10.
Comment 9 Mason James 2017-07-31 11:30:55 UTC
Pushed to 16.05.x, for 16.05.15 release